Today as I was working on my MacBook Pro, it became incredibly slow and almost impossible to work with. I spent five minutes trying to restart it from the system menu, and eventually I did.

It took it another ten minutes to switch off, and then I got the booting gray screen with the wheel indicator. I expected it to boot after a while, but apparently 20 minutes weren't enough.

I had to switch it off while booting and try again. During subsequent boot attempts, I would get a gray screen with a wheel and an empty progressbar that never moves (tested—I left it for three hours).

I inserted the Snow Leopard DVD so I could launch Disk Utility (as advised on the Internet) but it gave no effect. I still see the empty scrollbar, and worse, the MacBook turns off after a while (about 5 minutes after the start).

What are my next steps?

To recap my observations:

  1. The first time I restarted the system via menu so apparently it saved the state
  2. Second time I restarted it while booting
  3. I do hear the chime
  4. Then I see the spinning wheel, Apple logo and an ever empty progress bar
  5. Now it turns off on its own after a while

Later Update

I tried holding D to launch diagnostics as described here. I heard the DVD slot make a sound about ten times, and then it spat out the Install DVD. I saw no diagnostics, and then it turned off again.

Holding C with the DVD inside gives me ten minutes of the optical drive sounds as if it were stuck (to clarify, I never had problems with it before). Then it rebooted and got stuck again.

  • Try resetting your PRAM/NVRAM: support.apple.com/kb/ht1379
    – user10355
    Sep 19, 2011 at 20:38
  • @cksum: Thanks, just did that. I still get the gray screen and the progress bar is not moving.
    – Dan
    Sep 19, 2011 at 20:41
  • 1
    Not to get you panicked, but these types of hangs are usually (from my experience) indicative of a hardware fault somewhere (could be choking on an external disk, or some internal component). During the boot sequence, can you hold down CMD+V (verbose) mode and see where it's failing? Or rather, where it's choking?
    – user10355
    Sep 19, 2011 at 21:35
  • 1
    disk0s2 is your main partition. And it looks like it's damaged. Worse yet, it looks like it's not the partition scheme, but the drive itself. You will have to pull it and run diagnostics to confirm. To boot, you will likely have to from an external drive/usb stick. If you can't make one using this on another Mac: support.apple.com/kb/dl1433 then you will have to bring it into Apple I'm afraid. It sounds like your disk died :( What year is your MBP?
    – user10355
    Sep 19, 2011 at 21:45
  • 1
    Take to an Apple Store (not an authorized Apple repair shop). They'll happily fix it for you. Seeing as you are still under warranty. As for the RAM, that is quite easily user serviceable (read your owner's manual). You should just pick up 8 GB on the cheap (newegg.com) and do it yourself.
    – user10355
    Sep 20, 2011 at 0:15

4 Answers 4


One more thing to try: Boot in Safe mode holding the Shift key at the startup sound. If the internal drive is bad (failed drive or borked OS), this won't work.

If you have an external drive as a full bootable backup (and I hope you do), connect it a power it up. Then try booting the Mac holding the Option key, and select the external drive.

If you have another Mac, connect the sick Mac to it and boot the sick Mac in Target mode (hold the "t" at startup sound).

If either works, copy all critical data to the drive you are booted in.

I agree that there is at least one hardware failure involved.

  • I mark your answer as correct as there doesn't seem to be anything else I could do. Unfortunately, it was a serious hardware failure, but in the end I just went on buying an SSD as a replacement, and currently I'm happy.
    – Dan
    Sep 23, 2011 at 18:18

I took it to an Apple Store and they were going to replace the hard drive but were going to do nothing about my data. I took it to an Apple Repair Shop and they replaced the hard drive and recovered my data at no charge. It's as if nothing ever happened. Not sure why someone mentioned not to take it to an Apple Repair shop but I'm happy with the results.


What I would do is make a Bootable disk drive, Just google "How to make a mac 10.9(Or lower) disk drive and plug it in. While booting, hold the option key. the file should come up. then install the OS onto the HDD or SSD.

  • 1
    Hi and welcome to Ask Different! Answers that include the phrases "just google..." or "just search..." are often downvoted on Stack Exchange sites. When ever possible please include links to specific sites or, even better, summarize the instructions behind a link in to your answer here. This fights link rot and makes it easier for the question asker to solve their problem by looking at just your post and nothing else (unless they're curious to learn more).
    – Ian C.
    May 4, 2014 at 18:54

I'm having the same problem with my MacBook Pro (early 2011). At one time I was able to run TechTool and attempt to repair the hard drive. This worked for a short time, but after a restart for another reason, I get the same problem.

I'm not sure if this has anything to do with FileVault 2 as well, but I did notice that my drive (for whatever reason) was not formatted with 'Journaling' enabled. You could try checking that and also run TechTool to see if it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .