10

When I'm out of the country and don't have wifi or data and I want to send a text message to another iPhone back in the UK, it won't let me send a standard text message . It wants me to send an iMessage as it recognises I'm sending to another iPhone , but I do not have any data allowance or wifi so it won't let me send an iMessage anyway and I can't find a way for forcing it to send a text SMS message.

I've looked in settings and turned off my iMessage, and the option to send text SMS only is not there anymore. I used to be able to do this before iOS 10. Is there a way I can send a standard text?

3

Go to settings and turn off iMessage. Send your message. (Optional) go back to settings and turn iMessage back on.

I just verified that this works in iOS 10.

  • That is awfully complicated, check the answer from Andy, it works while sending / as long as its not delivered. – Damian Vogel Jul 17 '18 at 10:54
2

A message from Apple Support Chat:

I checked with a few resources on this and it seems that the feature is no longer available in iOS 10 to be able to chose how to send a message. We would still have the option to turn on Send as SMS which will automatically send a message that wasn’t able to be delivered as an iMessage before.

1

You can, press and hold the unsent iMessage and a menu will pop up with the option

  • 1
    No, it doesn't work like that in iOS 10. – fsb Oct 5 '16 at 18:42
  • 1
    @fsb it still works like this for undelivered messages. Once it comes as delivered this option disappears – Justin Oroz Jan 23 '18 at 4:45
  • I can attest that it doesn’t always work in iOS 12. Failed texts to my wife would not show up in the thread. All you get is a pop up error and the message remains in the text box where you compose the message. – hepcat72 Aug 23 at 0:17
0

It's still possible, but You have to send message to phone number instead apple ID (like email address). After enabling Send as SMS in Settings > Messages of course. It works exactly how it used to work in iOS 9, but crucial is sending message to phone number.

Photo attached below

  • 2
    This did not work for me with iOS 10.1.1. It recognized the phone number and sent a blue iMessage. – Michael Tsai Nov 18 '16 at 20:50
  • @MichaelTsai until the message is delivered You still can press and hold on message and send it as text message. Just checked it and it works. – Kuba F. Dec 15 '16 at 8:04
  • Thanks, but the issue for me is that messages that it says are delivered are not. So I need to resend messages that it thinks were delivered as SMS. – Michael Tsai Dec 15 '16 at 16:19
  • Yes. @MichaelTsai is right. If the person you’re sending to uses iMessage on their computer, it will be marked as delivered even though the person’s phone did not receive it. That’s what was happening to me when a friend who we were meeting in Mexico was texting me. She thought I was getting the messages because my work computer is always on. I’m sure it received the message just fine, however I never got it here in Mexico. – hepcat72 Aug 23 at 0:10
  • In iOS 12, even if you send to a phone number, the message will not (always) appear in the thread. All you get is a pop up error stating you have to turn iMessage on. And that error happens whether iMessage is on or off. However, it seems in some cases, the message will convert to SMS, as it did with the iMessage group thread with my parents. I cannot explain why that message converted, but texts to my wife wouldn’t. – hepcat72 Aug 23 at 0:14
0

I just encountered this issue and I’m on ios 12.2. Sprint is my carrier. I had tried all of the solutions above before finding this page. None of them work. I spent a few hours chatting with both sprint tech support and sprint worldwide support (via a WiFi connection). After giving up trying to find a resolution to the sms issue, they informed me that my plan included free data roaming. (I hope to God that’s actually true because i know it didn’t used to be.)

Anyway, I don’t know why I could send sms messages to my parents from Mexico to the US, but not to my wife here with me in Mexico. Every time I tried to send her a text, regardless of the iMessage and Send as SMS settings, I would get an error stating:

sms error

I.e. I tried iMessage on and off and send as sms on and off.

Incidentally, even though I had no icon indicating a data connection, I was receiving sporadic connectivity such as app notifications for emails and other communications but whenever I tried to use an app, I would get an error saying I wasn’t connected to the internet, such as:

enter image description here

Also, while I was able to call my parents, every attempt to call sprint via their 888 number immediately “call failed”.

Other things I tried: I made sure that I was sending messages to my wife’s phone number and not her iCloud address. I tried changing the phone type in contacts from iPhone to mobile. I tried adding 1 in front of her number. I also tried adding + in front of the 1. I tried turning off automatic cellular network selecrion and switching networks manually (settings->cellular->network selecrion->automatic).

Finally I discovered a workaround. You can send sms messages to google voice numbers and luckily, both my wife and I have google voice numbers. I had forwarding turned off on my GV account, so I had to turn it back on in order to receive, since using the GV app requires a data connection.

For anyone who tries to look for an actual solution, instead of a work-around, please note, every time you test a solution above, you have to make sure WiFi is off. Note also that Apple disabled the option to tap and hold a message to send as sms. It’s supposed to work automatically if you enable send as sms, but that only works if you have iMessage enabled and there appears to be a bug where if you turn iMessage off and try to message someone whom you’ve imessaged before, it refuses to send an sms in some cases. It converted to sms when I messaged my parents even though the thread had been iMessages up to that point, so I’m not sure what other circumstances are needed to encounter the bug. It could have to do with the location of the recipient, whether it’s a group thread or not, or... it’s anyone’s guess.

-1

You can go in Settings > Messages > Send as SMS

  • That will only send as SMS if iMessage is not available. If iMessage is available it will not send as SMS so there's no way to 'force SMS' anymore. – fsb Oct 5 '16 at 18:52
-1

If you turn off iMessage off on Preferences > Messages, all messages come out as Text Messages; that is why the "Send as SMS" option is no longer present.

You must log in to answer this question.

protected by Community Oct 13 '16 at 14:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .