I just installed macOS Sierra and when I log into the Recovery mode, I do not have the Utilities menu in it. Only the 4 options, Restore From Time Machine Backup, Reinstall macOS, Get Online Help and Disk Utility.

How can I access Terminal from OS Recovery?


7 Answers 7


This is a bug in the recovery Mode, also the same issue if you create a USB Device for install. Try to load Recovery Mode again and choose one the the four available options that should get the menu back.

I've tried boot from USB Device three times until the menu was visible.

  • i tried that as well.. i dont see the menu even after selecting any of the options.
    – Addy
    Commented Sep 23, 2016 at 13:52
  • 2
    If you able you can try start from USB. Download Sierra from Apple Store if you not have the app in your applications. If the Installers appear quit it. Insert an USB Device in your mac (at least 8 GB) and copy and paste the following command in your Terminal: sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ macOS\ Sierra.app --nointeraction Change /Volumes/Untitled with your USB Volume name. Try booting from USB and test whether you can choose Terminal from there.
    – dante12
    Commented Sep 23, 2016 at 15:00
  • 1
    I created the USB installer and was able to access terminal. thanks for the help.
    – Addy
    Commented Sep 24, 2016 at 22:07
  • I was personally able to get a menu bar by restarting like 4 times.
    – zneak
    Commented Dec 21, 2016 at 22:35

You need to click the Utilities menu, as shown in the image below, then click Terminal.

If you do not have the Menu bar showing then you can either try rebooting to see if that makes any difference or just click, e.g. Disk Utility and then close it to see if it will bring the macOS Utilities Menu bar up. (As noted by dante12)

Otherwise try holding down Option-Command-R to start up from OS X Internet Recovery to access Terminal from there.

enter image description here

  • Yes, on Sierra do not follow the instructions that say pick Disk Utility and then choose Utilities -> Terminal. The Utilities option is on the previous screen as shown in the above image. Commented Jul 19, 2019 at 17:20
  • Do you know once you get to the Terminal, how do u come back to MacOS Utility screen. I don't have option to do that
    – amitnair92
    Commented May 12, 2020 at 11:14
  • 1
    @amitnair92, Just quit (⌘Q ) the Terminal application to get back to the normal screen. Commented May 12, 2020 at 13:29

After battling this problem for hours I just found a great, reliable solution!

If you reboot holding Command-R-S then you can get into an undocumented combined recovery mode and single user mode, this will go directly to the command prompt without the graphical interface but you will be in recovery mode and can enter the csrutil disable command successfully.

I did this by triggering the reboot from the device selector dialogue in the regular recovery mode on Sierra on a Macbook 2010 but it probably works via other methods.

So happy to have found a reliable workaround for this at last, hope it will benefit others.

  • This is only solution that works for me on macOS 10.12.5. Weird for me is that csrutil cannot be found even I have recovery partition. This solution is fast and takes you directly to single user mode thus able to type command fast! No more wait like 10 minutes to enter recovery mode if you know how to do things with commands. Thanks!
    – haxpor
    Commented May 12, 2017 at 16:07
  • This one works great, the accepted answer didn't. No matter how often I booted into recovery and no matter what I selected in the fist dialog, I never got the menu to appear.
    – Mecki
    Commented May 15, 2018 at 12:09
  • 1
    What’s the difference between this and simple single-user mode (Cmd+S)?
    – kirelagin
    Commented Jun 27, 2018 at 20:16

Clearly too late for you now but it seems that with Sierra, in order to get the recovery programme opening fully (properly) "Command-R" needs to be held down during the full length of the booting process. Only then do you seem to get the full menu bar appearing as normal.

  • I tried this, and it does not seem to make a difference.
    – Hans Nowak
    Commented Jan 4, 2017 at 3:06

The usual recovery mode/installer task bar has several menus. Terminal is usually reached from the Utilities menu.

Upon boot, the task bar that is first presented is that shown with the "language chooser" dialogue, which just has a language chooser menu.

Once the language has been chosen, the task bar should change to the usual menu, but instead the "language chooser" task bar remains.

In order to get the correct task bar to appear, moving the cursor around at the top of the screen (making the task bar appear and hide repeatedly) will quite quickly (only took me a few seconds) result in the correct task bar appearing.

You should now be able to open Terminal from the Utilities menu.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions
    – Allan
    Commented Sep 26, 2016 at 0:55

I too had this problem and it was super frustrating. I've had to deal with this deleting the .plist thing ever since I installed an aftermarket battery. It's really not that difficult, but when you have to disable the SIP it adds an extra annoying step. The worst thing of all was that, when using OS Sierra and booting in recovery mode, I couldn't see the terminal from the menu bar. I just had that stupid "Language Chooser". Making a USB book disk worked, but only after I restarted that way twice. The first time I still didn't see an option to access terminal. It's really annoying that it might or might not show up. It's like I'm blowing dust out of an NES cartrdige. Thanks for all the helpful info in this thread though. I can confirm after jumping through those stupid hoops I was able to get my computer working correctly again. All that for virtually no difference in the stupid OS. Either way, USB boot disk is that way to go in order to get to terminal from Recovery.


I had the same problem. I tried to boot from USB install but it didn't work. Took me a day to figure this out but I solved the problem by putting back the original battery and booting from USB install. The terminal and all the recovery mode features reappeared.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .