Since I upgraded my Retina MacBook Pro with macOS Sierra GM (16A319), rebooting the computer takes 20-30 minutes. I select Restart... from the apple menu, everything logs out, then the Mac hangs on a black screen for the rest of the time. I even have a mouse cursor. After a while it reboots normally, and booting takes 10-15 seconds as usual. If I force shut down, I can boot normally (except for the warning, that the computer was not shutted down properly).

I've tried selecting Boot disk in System preferences, change the boot disk from terminal, but it seems the problems is with the shut down operation.

I have only TripMode's kernel extension beside Apple's own modules.


I had the same issue and it seems to be fixed when upgrading to MySQL 5.7.15


  • it's not necessary has to be the version 5.7.15 for mysql. It can be any fresh build compiled specifically for MacOS 10.12, you may check it from the command line, which one are you running: $ mysql --version
    – Farside
    Dec 29 '16 at 15:27

Ok, I've found the solution: mysqld is the problem, version 5.7.13 can't be stopped (even from Activity Monitor or with kill), so macOS waits for it to stop until a very long interval.

Solution: Untick automatic startup in MySQL preference pane, reboot once slowly, then the second reboot will be fine.

  • 1
    Do you know how to fix the problem without disabling automatic startup? I disabled it, and it worked, but I want my MySQL to autostart.
    – Tijme
    Sep 25 '16 at 12:39
  • I think we have to wait until a new release which supports macOS 10.12.
    – gklka
    Sep 25 '16 at 12:51
  • @gklka, check the answer, there already been released Distrib 5.7.17, for macos10.12 (x86_64).
    – Farside
    Dec 20 '16 at 12:35
  • Thanks! For my case, I decided to delete it. There are manual steps doing in terminal to remove mysql from macOS. Also before first reboot after deleting mysql, I have to make sure there's no mysqld process running even I kill -9 <process-id> and it's gone. But it keeps coming back for 2nd time. Thus others might need to verify it's gone for good before rebooting to take effect.
    – haxpor
    Feb 27 '17 at 19:42
  • @gklka Sorry for reviving this topic, but due to this, I found out that mysql was the issue for me, too, even having the latest version (5.7.17 on macos10.12). I did the steps in your solution and it worked. How did you find out that mysql was the problem? I'm curious, because I want to know what to do if this eventually happens with other applications. Mar 20 '17 at 12:11

It seems it's mysql is keeping it in the loop during the reboot.

You'd need to check your build of mysql from , you will see something alike that from MacOS Sierra:

$ mysql --version
mysql  Ver 14.14 Distrib 5.7.9, for osx10.9 (x86_64) using  EditLine wrapper

You'll notice, that you having an old build, which needs to be updated. You can download the fresh from the official MySQL website, or via by retrieving the latest formulas/packages:

$ brew upgrade
$ brew outdated
$ brew upgrade mysql

Make sure you gotten the fresh build by running command from terminal:

$ mysql --version
mysql  Ver 14.14 Distrib 5.7.17, for macos10.12 (x86_64) using  EditLine wrapper

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .