After upgrading to macOS Sierra yesterday, I notice that the system keyboard shortcut to shut down the computer no longer works.

As documented here, before the upgrade you could shut down the computer using Control–Option–Command–(Power button or Media Eject).

After the upgrade, the system seems to ignore the "Control–Option–Command" combo and merely sleep the display as if I had tapped the Power button alone.

Do you know of any documentation on how to restore the old shortcut?

  • 1
    I think this is a bad advice. Holding the power button for 5 seconds will just turn off the machine. All open documents will not be saved/cached and are thus gone. – oa- Sep 22 '16 at 14:14
  • surly its just easier to press the power button, then select shutdown? – OzzieSpin Sep 22 '16 at 17:20
  • I found the issue: github.com/tekezo/Karabiner-Elements/issues/124 Before upgrading to macOS Sierra, I was using the Seil app. Immediately after upgrading, Seil generated a notification that it wasn't compatible with the kernel. I went to the site to get a new version, and found a notice from the developer suggesting that Seil users download Karabiner Elements instead. Uninstalling Karabiner Elements resolved this issue for me. – John Stephens Oct 3 '16 at 1:43

Ctrl + Cmd + Opt + Power/Eject still works in macOS Sierra. I just tested it with an upgraded install (El Capitan to Sierra) on an MBP Mid-2014. Please see if another keyboard shortcuts overrides the shutdown command:

System Preferences > Keyboard > Shortcuts

After upgrading to macOS Sierra my keyboard shortcut for Spotlight (CMD + Space) was changed to Ctrl + Space. I had to change it manually to restore the functionality.

Edit: John, please do the following: Backup all PLIST-files starting with com.apple. + pbs.plist + ".GlobalPreferences.plist (in Terminal:

cp -f ~/Library/Preferences/.GlobalPreferences.plist ~/Desktop
# this will copy the file as a backup to the Desktop

rm -f ~/Library/Preferences/.GlobalPreferences.plist
# this will delete the original file

Also backup the folder ~/Library/Caches/. Now delete everything inside this folder. Empty the trash and reboot.

  • 1
    Thanks, oa-. I don't see any overlapping shortcuts in the Keyboard pref pane, but I did notice (through experimentation) that Siri was using the same shortcut as Quicksilver. That wasn't noted in the Keyboard Shortcuts panel though, so I don't think that it shows a comprehensive list of possible conflicts. – John Stephens Sep 22 '16 at 17:22
  • 1
    Thank you, oa-—that worked: I created a test profile with administrative privileges, and the shutdown command worked instantly. Now I know that the problem is based on the state of my default profile. Do you know any further steps I could take to diagnose it? – John Stephens Sep 22 '16 at 19:27
  • 1
    Thanks again. I deleted the plist files you highlighted one by one, exactly as you described, restarting after each and trying the shortcut again. The shutdown command still doesn't work in my default profile. I still have the files I copied to Desktop. Any ideas what I can do next? – John Stephens Sep 23 '16 at 18:42
  • 1
    John, thanks for reporting back. In this case do the following: Backup all PLIST-files starting with com.apple. + pbs.plist + ".GlobalPreferences.plist (in Terminal: cp -f ~/Library/Preferences/.GlobalPreferences.plist ~/Desktop (this will copy the file as a backup to the Desktop) rm -f ~/Library/Preferences/.GlobalPreferences.plist (this will delete the original file) (to your desktop) and remove them at the same time. Also backup the folder "~/Library/Caches/". Now delete everything inside this folder. Empty the trash and reboot. – oa- Sep 23 '16 at 19:07
  • 1
    That worked! The shutdown shortcut is back. Do I need to do anything with the .plist files I backed up? – John Stephens Sep 23 '16 at 19:41

I was wondering the same. Used to shut down by holding power button for 1.5 sec. That feature seems to be gone with Sierra. This shortcut seems to work now: Control + Power will bring up the window for shutting down.

Found here: https://support.apple.com/en-us/HT201236

According to Apple Support, there are two shortcuts for shutdown:

Control–Option–Command–Power button or Control–Option–Command–Media Eject

I tried the power-button shortcut on my MacBook Pro Mid 2012 with macOS Sierra 10.12.4 and it worked similar to the old eject-button shortcut (maybe a little slower, but that could be the new OS). I assume Apple added the additional shortcut for newer devices that don't have optical drives and eject buttons, but they neglected to maintain the eject-button shortcut for the older machines within the Sierra update. Just more infinite wisdom from Apple.

UPDATE: I found that the standard Control–Option–Command–Media Eject does indeed work with Sierra. It seems that, at least on my machine, the key remapping program Karabiner and the Sierra-compatible version Karabiner Elements causes the Eject button to not register at all. When I disable Karabiner, the shutdown shortcut works normally. I did, however, find that Karabiner Elements does allow another key to be remapped as Eject. This won't work well on the limited internal keyboard, but for the external wired keyboard I set up one of the useless function keys (F19) as the Eject button. Now, Control–Option–Command–F19 works with the external keyboard and shuts down the computer.

Work around: system Preferences> Shortcuts > Move Focus To The Menu bar (which is CTRL F2) Turn that on, and use it to navigate to the Apple Icon, then use your Down Key to Navigate to Shut Down, or Restart or whatever...

Also with fn + power. Then select Shut Down with return key.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.