After updating to macOS Sierra, the OS no longer seems to automatically authorize network-mapped folders on system login. I have mapped NAS drives to connect to on startup, using System Preferences > Users & Groups > Login Items.

Keychain does save the login information, but it only appears pre-filled, and the network locations aren't automatically mounted on start-up.

So every time I boot the machine, I am presented with a "Connect" dialogue with pre-filled passwords.

In El Capitan, there was no need to manually authorize mapped network locations.

I don't know if changing to an iCloud-based Keychain and Two-Factor Authorization in conjunction with the Sierra updated changed anything.

I have tried removing the mappings from Login Items and adding them again, as well as rebooting etc. I have tried this on two separate computers and I have the same issue on both.

enter image description here

  • Have you tried clearing all of the keychain entries? I on occasion find an old keychain entry that's invalid that the system sometimes uses and prompts me with a dialog .. and sometimes it doesn't and just authorizes silently. Removing all of the entries and re-entering it manually and saving it in the keychain then rebooting usually solves my issue, but I haven't run into it with network volumes, only mail accounts. – Harv Oct 11 '16 at 20:31
  • @Harv I believe I did that on the first day of the issue surfacing, yes. – P A N Oct 11 '16 at 20:33
  • I'm having the same issue after upgrading to Sierra – Fergus Oct 15 '16 at 5:09

There is an update from Apple.

When connecting to a server that requires a user name and password, macOS Sierra 10.12 or later asks you to click Connect, even when the name and password have been saved in your keychain. This helps you to avoid transmitting login credentials to a server you didn't intend to connect to.

If you want to disable this security feature so that you can connect without providing additional confirmation, follow these steps:

  1. Update to macOS Sierra 10.12.2
  2. Open the Terminal app
  3. Enter the following command: sudo defaults write /Library/Preferences/com.apple.NetworkAuthorization AllowUnknownServers -bool YES
  4. Enter your administrator name and password when prompted


To disable this command and return to the previous more secure behaviour, follow these steps:

  1. Open the Terminal app
  2. Enter the following command: sudo defaults delete /Library/Preferences/com.apple.NetworkAuthorization AllowUnknownServers
  3. Enter your administrator name and password when prompted

@Winterflags I believe you're experiencing a glitch, because I'm using Mac OS sierra and it worked 100% as intended/expected.

If you want to repeat my steps, I did the following:

  1. Finder > Connect to Server
  2. I browsed and connected to another mac in the house and selected root volume
  3. As the login details were already in Keychain, the volume opened.
  4. Finder > Go Computer - this showed my local volume and the mounted volume
  5.  > System Preferences > Users & Groups > my account > Login Items
  6. I dragged the mounted volume to the Login Items. It showed the volume name and its kind is "Volume"
  7. Logged out.
  8. Logged back in - volume auto-mounted without any prompts.

I guess I would go with Harv's suggestion. Remove all keychain entries dealing with that volume. Maybe, for good measure, change the password used to access the volume so that you know it's different from anything that might be in keychain. Try again and see if your results are different.

Good luck.


this is new apple feature: you can no longer create items in /Volumes unless root (

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions – Allan Sep 23 '16 at 12:24
  • 4
    I'm not sure that's it. The system isn't asking for a password for admin, it's asking for credentials for the remote system. – Alan Shutko Sep 23 '16 at 16:36
  • 3
    Apple have closed the case with the following response: This issue behaves as intended based on the following: It was requested by security, you can no longer create items in /Volumes unless root. We are now closing this bug report. – Willkuer Sep 25 '16 at 7:04
  • 1
    @Willkuer Please add that statement to your answer – P A N Sep 26 '16 at 14:45
  • 7
    This answer is absurd. Auto-mounting a volume at login has zero to do with needing to be root to create items in /Volumes. You are misinterpreting Apple's response to apply to this situation (and I'd be curious to see what the original report to them stated, since I have a feeling it wasn't anything to do with mounting shared volumes through the GUI). If you were correct, the login window would be a security prompt, not a network login, and it would require that SIP is disabled and you have a root user set up with a password. None of which apply to this question. – tubedogg Sep 29 '16 at 20:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .