3

After I ran the macOS Sierra installer to start installation, my 2010 Macbook Pro wouldn't start anymore. It would get to the grey startup screen, flash the Apple logo for a second, and then switch to a crossed circle, and periodically restart that sequence.

Boot error logo

I got into verbose mode by starting my computer with Cmd+V and saw error messages like:

efiboot loaded from device: Acpi(PNP0A03,0)/Pci(1F12)/SATA(0,0)/HD(Part3,Sig4B75...)
efiboot file path: \System\Library\CoreServices\boot.efi
ERROR!!! Prelinked kernel corrupted
ERROR!!! Load prelinked kernel with status 0x000000000000001b
Error loading kernel cache (0x1b)
Error loading kernel cache (0x1b)
...

How do I get my computer back on track?

  • Does Safe Boot rebuild this? Edit: From support.apple.com/en-us/HT201262 : "Deletes font caches, Kernel cache and other system cache files" – MacManager Sep 22 '16 at 21:18
  • Didn't try and installing Sierra from a separate installation media solved my problem, but based on the description of safe mode on Apple's website, my best guess is that it wouldn't. That's a very early boot error. – zneak Sep 22 '16 at 21:19
  • 1
    Ah, glad you're booting again!! – MacManager Sep 22 '16 at 21:20
2

Try to remove the corrupted 'prelinked kernel' first, then rebuild the kextcache.

From the Recovery HD (putting your own volume's name instead of "Macintosh\ HD") try those three commands in Terminal in succession (pressing 'enter' after each):

rm -f /Volumes/Macintosh\ HD/System/Library/PrelinkedKernels/prelinkedkernel 
touch /Volumes/Macintosh\ HD/System/Library/Extensions 
kextcache -u /Volumes/Macintosh\ HD 

See also:

man kextcache
  • I'm trying to upgrade from macOS Mountain Lion to High Sierra. I experienced the same issue as OP after trying to install High Sierra. Typing your commands restore the boot and I'm now booting again on macOS Mountain Lion properly. What happened to the "successful" High Sierra install that I did before experiencing that prohibitory sign after the install reboot? No idea. I've tried to upgrade to High Sierra many times, in vain, always facing this boot issue (Mac mini, late 2012). – kytwb Nov 15 '17 at 11:17
  • This worked for me perfectly!!! You totally saved me, thank you so much!!!!! (what I also did was removing some kernel extensions before that were not from Apple in /Volumes/Macintosh\ HD/System/Library/Extensions) – Lupurus Jun 16 at 21:49
1

It's still absolutely possible to boot from the recovery partition by pressing Cmd+R. This starts a stripped-down version of your current OS that's able to connect to the Internet, perform some manipulations, and reinstall itself. I don't know of a way to recover from this specific error without reinstalling an OS, though I speculate that grabbing the /System/Library/Kernels/kernel file from a healthy Mac and putting it on the computer could help recover.

Since I'll be reinstalling an OS anyway, I might as well install Sierra for real. From recovery, it's possible to run the Sierra-bundled createinstallmedia program to create an installer on a thumb drive or SD card:

"/Volumes/Macintosh HD/Applications/Install macOS Sierra.app/Contents/Resources/createinstallmedia" --volume "/Volumes/disposablethumbdrive" --applicationpath "/Volumes/Macintosh HD/Applications/Install macOS Sierra.app"

This puts a Sierra installer on the volume disposablethumbrdivre (erasing whatever it contained before) that can (probably) be used, instead of reinstalling El Capitan. This process is documented in more details on other sites.

-1

Guys just test your memory health, maybe one of them is not working well. That was my procedure and is working.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .