1

In iOS 9 and earlier, you could tap any notification center row to be brought into the app, usually deep-linked to the source of the notification. Swiping on the notification revealed other options.

In iOS 10, 3D touch or long press is used to get those other options, but simply tapping on the notification does not get you into the source app. Is there a way to do this in iOS 10?

1
  • It appears that I can swipe left to right on notifications on the lock screen. No luck on notifications inside notification center (swipe down from top of screen), though. – NReilingh Sep 22 '16 at 14:18
1

Every notification can be 3D touched (or long-pressed) -- not just those with other actions. After popping open the notification, tap on the application name and icon in the notification header to open the app.

0

I believe it's a bug in iOS 10.0.1. It seems to work about half the time, with no particular pattern between which notifications work and which don't (i.e. it's not a particular set of apps that work or don't work). One interesting note is that if a tap isn't working, and I 3D Touch the notification, even tapping on the resulting "enlargement" (for lack of a better word) sometimes doesn't work, either.

From the lock screen, swiping left-to-right on a notification opens up the app (unless the phone is still locked, in which case you get a passcode screen first). Swiping right-to-left reveals a Clear button which removes that notification.

6
  • I'm able to get it to work every time on my iPhone 6 just by tapping the app name. – fsb Sep 22 '16 at 2:07
  • I'm confused about the left-to-right swipe--isn't that how you switch from notifications to widgets? – NReilingh Sep 22 '16 at 2:12
  • @NReilingh From the lock/"wake up" screen, for lack of a better term, swiping left to right directly on a notification opens up to that app. Otherwise the action you described occurs (and also in any other context, i.e. on the notification pull-down from the top of the screen). – tubedogg Sep 22 '16 at 2:15
  • @fbara iPhone 7 here. I had this issue just now actually. I tried tapping on the notification literally about 20 times in various places - the app name, the notification message itself, blank areas on the title bar and notification message area...nothing worked until I used 3D touch to enlarge it and then tapped on it from there. – tubedogg Sep 22 '16 at 3:37
  • @tubedogg Maybe it's because I don't have 3D Touch that it works every time for me? It could be if you have 3D Touch you have to force touch, otherwise you just tap? – fsb Sep 22 '16 at 13:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .