So, I downloaded the second GM before the public release, tried to open it and got this error: The application “Install macOS Sierra” can’t be opened. I then downloaded the public release from the Mac AppStore, same problem.

I tried using chmod +x /..../Contents/MacOS/Install/InstallAssistant, made the app open but immediately stops responding.

Note: I did download both files from another Mac, put them on USB and brought them home, I always used this method and it worked, not working now. I'm on a late 2013 MacBook Pro (15 inch).

Any suggestions or ideas on why this error is occurring?

  • The app is corrupted or locked to a specific mac. You could try figuring out if it's broken with the 'file' and 'otool' commands or launch it from a shell and check the exit status code. Sep 22, 2016 at 0:13

1 Answer 1


I know it sounds stupid, but I compressed the file and transferred it to my personal Mac via USB, decompressed and it worked, but seriously couldn't find out what was causing that error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .