1

Since installing macOS Sierra my right alt key is being mapped to ctrl. This behaviour is also visible on the keyboard viewer, where pressing the left alt key clearly activates the alt functionality, but pressing the right alt key activates the ctrl functionality.

How can i change this back?

I am using a Swiss German keyboard, but the problem is present in all keyboard settings. The problem must be computer-specific, since i do not have the issue when using the same keyboard on another computer with the same settings.

The device is an iMac 21.5-inch, late 2013 (i7)

Thanks for your help

1

Apparently an old Karabiner installation (that however has never been used and still had the default settings) interfered even after deleting it. It was only after clearing the Trash and rebooting a few times, that the issue resolved itself.

  • Great! Mark it as solved when you get the chance :) – JMY1000 Sep 21 '16 at 21:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .