1

I can't seem to get Siri to work on my 2014 Macbook Pro. I click the icon and nothing happens.

Diagnostics and Usage data just seem to barf out a bunch of com.apple.siri attributes and ends with

Siri error = 0

The system logs have the line

Sep 21 20:44:13 baphomet com.apple.xpc.launchd[1] (com.apple.imfoundation.IMRemoteURLConnectionAgent): Unknown key for integer: _DirtyJetsamMemoryLimit

Has this been seen by anyone else? If anyone knows if these point to something funny in my setup it would be greatly appreciated.

  • That's a memory-management error. It looks like you don't have enough memory for Siri to work properly. Try to close some applications and try again. I'm not having any problems using Siri on my MBP. – fsb Sep 21 '16 at 19:48
  • 1
    surly the system would Swap, he should have enough memory to use Siri, unless ofc the system requires physical memory, and not SSD/HDD swap. open up Activity Monitor, go to the memory section, at the bottom theres a real-time graph, it should tell you how much ram is left, and also whats using the most. – OzzieSpin Sep 21 '16 at 20:03
  • That error doesn't have anything to do with the issue. People were getting it in previous versions of OS X before Siri was added. You can read about it here. apple.stackexchange.com/q/155458/4007 – Alistair McMillan Sep 21 '16 at 22:08
  • @yegods Are you behind a corporate firewall or proxy? – Alistair McMillan Sep 21 '16 at 22:09
2

Had the same issue and found out something that solved this for me. Apparently, my notification center process was disabled for some reason, I've enabled it via terminal by typing:

launchctl load -w /System/Library/LaunchAgents/com.apple.notificationcenterui.plist
killall NotificationCenter 

After that I disabled and enabled Siri via the settings menu and it seems to be working now.

  • That's what fixed it. I recall setting the notification centre off a while ago as an optimisation, so apparently it's used for Siri. Thanks! – yegods Sep 25 '16 at 10:18

You must log in to answer this question.

protected by Community Nov 27 '16 at 19:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .