0

I have just updated my OS to MacOS Sierra. I have connected my external Hard Disk Drive (HDD) and it is not displaying under 'Devices' in my Finder window. It worked fine before the update.

I am using a MacBook Pro With Retina (Late 2013), running MacOS Sierra (Version 10.12). My external HDD is a SeaGate Slim SL Media (500GB).

The external HDD shows up in the Disk Utility application. It also shows up on the About This Mac > System Report > USB. I am not sure what is wrong, the external HDD is identified but does not display for use in the Finder window.

I have read that it could possibly be in sleep mode and putting the MacBook to sleep (whilst connected to the external HDD) and waking it up again should fix the issue. However, this did not work. Nor did restarting my MacBook. It was also mentioned elsewhere that it may require extra power, so I attached the power adaptor to my MacBook and still, no success.

I do not wish to erase the contents of the external HDD.

Is there a way to get my external HDD to be working as expected with my MacBook?

Thank you very much in advance.

  • I believe the "extra power" comment would be in reference to the hard drive itself, not your computer. Does the hard drive have its own power brick? – tubedogg Sep 21 '16 at 21:01
  • @tubedogg it doesn't, no. I am using the same USB 3.0 cable that had come with the external HDD, it is the same cable that I have been using for over a year now. – Didar Sep 21 '16 at 22:43
  • Same issue here. No solution yet. Related topic apple.stackexchange.com/questions/253790/… – Nealz Sep 23 '16 at 19:14
  • @Nealz I recently connected it to a Windows OS and 'repaired' the device using the options that appeared upon connection. It worked fine on the Windows OS, I was able to use my external HDD as normal. Once I connected it back to my Mac, the same issue was still present. No sign of the device under 'Devices'. Works fine on Windows. Weird. – Didar Sep 23 '16 at 19:21
0

The 'Sharing and Permissions' option has been changed to 'Read-Only' for no apparent reason. This has happened to me previously, but it still showed up under 'Devices' in the Finder window.

I believe in the macOS Sierra update, this does not show.

Fix for issue: Download the Paragon Driver for Mac OS to gain access for Seagate external drives without having to reformat from the following link:

http://www.seagate.com/gb/en/support/downloads/item/ntfs-driver-for-mac-os-master-dl/

Install the Paragon Driver and follow the steps. You will be asked to restart your Mac. Once your Mac has been restarted, the external HDD will display once again under 'Devices'.

Note: This resolution allows you to have access to your external HDD to modify it as you wish. It does not reformat the HDD - so your data is safe.

0

I have a 2013 iMac and my 4GB WD My Book was plugged in, connected to the Mac, but not showing up in Finder under Devices as it always has. Clicked on the Mac name under Devices and there it was. I dragged the icon for the external hard drive to a spot under Devices and it shows up now.

0

Reviving a dead-thread, but maybe this will help someone.

I too have an External USB 3.0 Seagate 3-TB hard drive that works flawlessly in El Capitan, but doesn't even show up in macOS Sierra. I have two laptops of ~2 years difference, but one on El Capitan and the other on Sierra.

I had to use a USB Extension Cable to get it to mount on the Sierra machine. Can you believe that? My USB 3.0 doesn't work unless I downgrade the connection to USB 2.... Nice going Apple... Way to support USB 3.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .