The update to macOS Sierra wrecked scrolling with my Logitech Mouse (which uses Logitech Control Center).

The scrolling behaviour is erratic because I'm actually assaulted by two issues:

  • In native macOS applications, like Apple Pages, there is an ”inertia-ish” effect that slows down the scroll and introduces some sort of acceleration-like movement akin to the worst nightmares from Windows 10.
  • In third-party applications, like Google Chrome, the scrolling is quite fast but not fluid; it's choppy and non-linear with sudden jumps and stops. Because of this, it feels like the computer is laggy when scrolling a page, but it's probably due to the way the software scrolls.

Sierra just came out, but I'm not that hopeful that Logitech are capable of tending to issues like these, so I'm afraid I will have to do something about it myself.

I have tried checking the settings of System Preferences > Mouse and System Preferences > Logitech Control Center > Vertical Scroll but came up with nothing except temporary band-aid tweaks to make it feel better.

Edit, Broken Mouse Buttons: Also related to this, is the issue that the Forward/Back buttons on some Logitech mice have stopped working. I was able to mitigate this issue by binding those buttons to keystrokes in Logitech Control Center, e.g. ( + ) and ( + ) for Google Chrome. Possibly, something like BetterTouchTool, Steermouse, or USB Overdrive could be used to intercept the OS functions Forward/Back in case the keyboard shortcuts above aren't global for all applications. Regardless, with BetterTouchTool, you can set application-specific keystrokes and bind them to mouse buttons.

  • 2
    There are a lot of threads about it on Logitech's forums. See this and this for examples. Logitech has yet to really issue a statement other than a few weeks ago that Sierra was not yet released. Looks like we are out of luck for the time being. Great support, Logitech!
    – Josh
    Sep 21, 2016 at 19:18
  • 2
    For me, I just installed USB overdrive, and my logitech wireless mouse scrolls smoothly just as before upgrading to macOS Sierra. Sep 22, 2016 at 14:26
  • 2
    Logitech has posted an update for Sierra: support.logitech.com/en_us/software/…
    – Jan S.
    Sep 23, 2016 at 7:44
  • 1
    This problem also occurs when using Logitech Gaming Software for the Mac, latest version 8.79.52, which is the only supported driver option for users of Logitech's G-series mice. This software has not yet received a MacOS Sierra update: community.logitech.com/s/question/0D53100005c3Vp7CAE Sep 26, 2016 at 14:11
  • 3
    BTW, I'm experiencing similar problems with a Microsoft mouse, so it might be not limited to just Logitech Oct 5, 2016 at 21:05

7 Answers 7


The 3.9.5 version, published on Sep 22, 2016 by Logitech solves most of the issues. The scroll is smooth again in Chrome. Unfortunately the inertia is still a bit high in native apps like XCode, but not as bad as before I guess.

  • 3
    Note that there are some crash reports and Logitech has acknowledged the problem.
    – Jan S.
    Sep 24, 2016 at 3:23
  • 2
    I can confirm having still random system freezes with 3.9.5. That forced me to uninstall LCC Oct 3, 2016 at 15:50
  • 5
    The inertia problem still exists more me with 3.9.5.
    – Berry Blue
    Oct 9, 2016 at 2:46
  • 2
    I am having a problem with highlighting text while scrolling with the mousewheel. Not working at all.
    – Abram
    Oct 27, 2016 at 15:03
  • 1
    I have logitech G502 and seems like logitech control center doesn't support "G" series mouses. They have "Logitech Gaming software" for G series, but unfortunately the problem isn't fixed with Logitech Gaming software and it has no option for disabling scroll acceleration :(
    – Sarim
    Nov 4, 2016 at 17:52

Until Logitech fixes their drivers, I can confirm that using USB Overdrive is a viable workaround for the single-line scrolling issue on Mac OS Sierra using Logitech Gaming Software for Mac v8.87.92. I have not tested it with Logitech Control Center since my G700 mouse does not work with LCC.

What's interesting is that I have both LGS and USB Overdrive installed together, and all my mouse bindings in LGS continue to work correctly. I have USB Overdrive configured for "G700 Laser Mouse, Any Application" and under "Advanced Options" I chose "Configure Missing Buttons to do Nothing". I then configured Wheel Up and Wheel Down for "Scroll" using speed "Accelerated" (I also tested "1 Page", "1 line", "2 lines" etc) and it works correctly.

I now can scroll one line at a time using the mouse wheel in all my applications.

  • 2
    USB Overdrive worked. My Etekcity Scroll X1 finally registers a small/slow mouse scroll.
    – Harry
    Nov 30, 2016 at 13:03
  • 1
    Yes USB Overdrive worked, after the Logitech Control Center didn't work.
    – phocks
    Dec 3, 2016 at 2:48
  • 4
    You can also try SmoothScroll which fixes the Sierra issue and also adds animation to scroll ticks for a better experience.
    – gblazex
    Dec 14, 2016 at 10:35

Smooze helped me get rid of all annoyances, after several months of problems. After having tried some common suggestions like USB Overdrive and SteerMouse to no results, I tried this new app which also appears to be actively developed with new updates at the time of this post.

I found that Smooze was able to create the scrolling behaviour I like – which is non-smoothed linear scrolling with no acceleration curves. It also provides very customizable settings for those who likes smoothing, with different curve selections and speeds.

The paid version includes some additional features, like cursor gesture shortcuts, but I think you can solve the issues with the free version.

Note: If you're planning to use this app, you should uninstall Logitech Control Center or it might not work as you'd like. If you're dependent on LCC for special buttons like the Thumb Button and so forth, I recommend that you get something like BetterTouchTool and create custom bindings instead.

NB: My model is Logitech Performance MX.


MacOS 10.12.2 fixes the Smooth Scrolling inertia issues with and without LCC 3.9.5 installed.

Unfortunately, with LCC 3.9.5 installed on 10.12.2, there is an issue with highlighting text and scrolling, where the highlighted text loses its focus. There's a separate SE post for this issue.

  • My Unifying Software can't even open without crashing immediately after updating to MacOS 10.12.2 now. I remember how long it took Logitech to update the software for Yosemite... I hope it doesn't take that long to fix all these issues with Sierra. Dec 16, 2016 at 2:32
  • @GreatBlakes -- are you using v3.9.5? It was released in Oct 2016, and upgrading to it from 3.9.4 fixed the crashing issue for me. Dec 16, 2016 at 11:11
  • I am on 3.9.5 and after restarting a bunch it finally (seems to have) stopped crashing. I have noticed that the scroll wheel is very sensitive in VLC (volume goes nuts at even the slightest movement of the wheel). But I can at least use the mouse. Dec 17, 2016 at 18:33

Since the latest version of the Logitech Control Center still has a lot of issues (most notably, OS freezes/crashes), and since I was already using BetterTouchTools, I just uninstalled Logitech Control Center.

The scroll works fine without LCC and the only thing that was missing was the mouse button actions (back/forward and wheel left/right), but that was easily fixed using BetterTouchTools.

No more macOS crashes! :D

  • Does the "custom" Logitech mouse buttons work if LCC is removed? For instance, I use the "Lower Thumb" button to open Mission Control. With LCC installed and that button disabled in LCC, I can't add it to BTT. Some buttons can be added however, like "Middle mouse button" and Back/Forward.
    – P A N
    Oct 9, 2016 at 8:18
  • My mouse does not have the Lower Thumb buttons, so I don't really know that...
    – amfcosta
    Oct 12, 2016 at 9:57
  • still weird and soggy for me after uninstalling LCC... :(
    – kevnk
    Nov 17, 2016 at 22:12

This is a problem with more than Logitech mice. I had this problem with an old, generic Dell USB mouse as well.

USB Overdrive solved this problem right away.


It's odd - that's the experience I had after upgrading to Yosemite several years ago with my Performance Mouse MX – I'm surprised you had it working past that point!

For me, the best solution (though it did not perfectly mimic the previous behavior) was to install BetterTouchTool and use the "advanced" configuration options to get it to mimic the inertia and acceleration of the original behavior (in a way that playing around with the default OS X settings was unable to accomplish). Here's a screenshot of that dialog (not configured):

enter image description here

I tried installing new & old versions of the OS X Logitech drivers and control panel to no avail; a few months later, I ended up switching to a combination wired/BT Razor mouse instead (even though I don't game) just to experiment with this issue and discovered it only affected/plagued Logitech mice..

  • Thanks for the suggestion – I have looked around in BTT already but I couldn't find anything to help out with this issue. The closest thing I could find was under Normal Mice but it doesn't really address the scrolling, AFAIK. I also tried overriding scrolling with Steermouse to keystroke rows up/down but didn't work. Let me know if anyone finds something with BTT/Steermouse etc to fix scrolling. It is however possible to fix the Back/Forward issue by assigning keyboard shortcuts to the buttons in Logitech Control Center or BTT.
    – P A N
    Sep 21, 2016 at 20:44
  • I also have an Performance Mouse MX, but I hadn't updated the software for ages (until yesterday). Maybe that's what kept it working through Yosemite/El Capitan.
    – P A N
    Sep 21, 2016 at 20:46
  • 1
    This didn't work at all for me.
    – Berry Blue
    Oct 9, 2016 at 3:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .