0

I updated to Sierra yesterday and now my Time Machine backups to my WD MyCloud EX2 NAS aren't working any more. Scheduled backups get stuck in "Looking for backup disk..." in Time Machine preferences. Does anyone have ideas on how to resolve this?

Here is what I did to troubleshoot:

  1. I am able to access the backup drive over the web interface http://wdmycloudex2.local/ and that page mentions my firmware is up to date and both the drives are healthy. I can also connect to smb://wdmycloudex2.local and afp://wdmycloudex2.local from Go > Connect to Server in Finder.
  2. I went in Time Machine preferences and turned it all off.
  3. Rebooted WD NAS Confirmed power-on test passed by going back to http://wdmycloudex2.local/

  4. Went back in Time Machine preferences and tried to add the drive back.

Time Machine fails with this error when I try to add the drive back: enter image description here enter image description here

  • 1
    Smb isn't supported for time machine. It never was, and could only be hacked to force it to work in some cases. – John Keates Sep 22 '16 at 0:27
1

Please try to connect to your disk using afp://yourserver.local

If it shows up in your Finder (CMD+K) you should be able to mount it in time machine.

  • 1
    Yep, this works. Thanks for the tip. Seems like it's an issue with the MyCloud - community.wd.com/t/… – Zach Rattner Sep 22 '16 at 15:08
  • @ZachRattner Great, I'm glad this solved your issue! – oa- Sep 22 '16 at 16:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .