3

Every time I try to enable iCloud Desktop and Documents Sync it spins the spinner for a while and it looks like the setting is enabled, but as soon as I reopen settings it is deselected.

Console produces errors like these:

bird [ERROR] can't open Documents or Desktop <private>; error 2 (<private>)
bird [ERROR] Failed to apply sync policy: -1 for folder type: 2, error: <private>
accountsd [ERROR] iCloud Desktop Settings change failed: <private>, resetting to old value

Any suggestions?

  • Could it be something wrong with your account? Maybe your iCloud account is causing the issue. – Edric Sep 21 '16 at 14:40
  • Everythin else seem to be working. I have payed and enough free space in the cloud. – firedev Sep 21 '16 at 15:22
  • 1
    I had the same issue but the 10.12.1 update (today) fixed it. – Arno Oct 24 '16 at 19:02
  • I am getting this on a brand new Mac starting with 10.14.2. Did you find any solution? – Elliot Chance Mar 20 '19 at 3:52
  • @ElliotChance Flipping the switch back and forth finally enabled it. – firedev Mar 21 '19 at 14:07

You must log in to answer this question.

Browse other questions tagged .