Introduced in macOS Sierra, the user can control how fast the Mission Control animation moves to the “end view”, by how fast the action is performed on a trackpad.

I think the default setting is much too slow, and I don't want to overdo the gesture each time just to get better efficiency out of the animation.

This 2012 article refers to settings like these:

defaults write com.apple.dock expose-animation-duration -float 0; killall Dock

for fast animations, and to reset:

defaults delete com.apple.dock expose-animation-duration; killall Dock

I have tried them in Sierra and they don't work.

Here is a video of the approximate behaviour of Mission Control (source).

up vote 10 down vote accepted

Aidan Marr is correct. BetterTouchTool can be used to get the old behaviour.

First, disable three finger swipe up in System Preferences > Trackpad.

Trackpad prefs

Then, use BetterTouchTool as follows:

  1. Select the "Trackpads" tab at top and "Select Application:" "Global" at left.
  2. Click "Add New Gesture"
  3. Select "Three finger swipe up" as your gesture and "Mission Control" as your action.

BTT Screenshot

The old behaviour is now restored and you will be able to use:

defaults write com.apple.dock expose-animation-duration -float 0.1

Note, that you can use a similar process for "App Exposé"

Bonus Tip: Since "Mission Control" is still a standalone App on your system you could use the utility of your choice to invoke it. For example, you could have Keyboard Maestro invoke it with a particular keystroke. Invoking the app this way uses the old (pre-Sierra) behaviour.

  • I tried this and it does seem to work. Unfortunately it brings some other problems, namely: 1) You have to use the same gesture to open/close Mission control, i.e. can't use the opposite gesture, and 2) The mouse cursor tended to move along when doing the gesture, at least on my MacBook. I'm accepting this answer – at least until there is a known terminal command for macOS Sierra without the requirement for third-party apps. – Winterflags Oct 25 '16 at 19:08
  • I'm not experiencing (2) on my machine. I wonder if it has anything to do with the value for Basic Settings > Gesture sensitivity and/or trackpad speed on the same page. – Mark Thomson Oct 26 '16 at 17:53
  • 1
    Alternately I would consider experimenting with the options at Advanced Settings > Trackpad > Swipes > 3 & 4 Finger Swipes. – Mark Thomson Oct 26 '16 at 17:55
  • Testing it out with a 4 finger tap, works quite good. – Winterflags Oct 26 '16 at 17:58
  • 3
    @Winterflags I ended up setting four-finger swipe UP and DOWN to mission control. That way, you can exit mission control with the opposite action! – aashah7 Nov 2 '16 at 15:10

Here's a quick list of animation-related tweaks for macOS Sierra.


Don’t animate opening applications from the Dock

defaults write com.apple.dock launchanim -bool false

Speed up Mission Control animations

defaults write com.apple.dock expose-animation-duration -float 0.1

Remove the auto-hiding Dock delay

defaults write com.apple.dock autohide-delay -float 0

Remove the animation when hiding/showing the Dock

defaults write com.apple.dock autohide-time-modifier -float 0

Increase window resize speed for Cocoa applications

defaults write NSGlobalDomain NSWindowResizeTime -float 0.001

Once done, you'll need to killAll Finder && killAll Dock to restart those programs.

You can find a lot more by searching for "dotfiles", and the source for the changes above (as well as many, many more) can by found in this particular dotfile by Mathias Bynens.

  • 8
    Are these really tested on Sierra? You can see that your answer is basically the same as in my question. I have tried it and it didn't work. – Winterflags Sep 21 '16 at 17:21
  • 4
    Yes, they have been tested. The expose animation does present an issue because it now follows the speed of your gesture, just like the show desktop gesture. I know several people are looking for a work-around. But the animation time is still set and recognized in Sierra, which means that the work around will probably look like disable-follow-fingers -bool false which will cause the animation timeframe to take effect. I'll update if I hear of anyone who finds that particular setting. – Shelton Sep 21 '16 at 17:28
  • 6
    Another note, you might turn on reduced motion (Accessibility Settings). To me, it doesn't seem to solve the issue, but it may "feel" faster, because the sliding animation goes away. – Shelton Sep 21 '16 at 17:41
  • 2
    Thanks for the tip. The Sierra controllable "peeking" Mission Control function can be quite useful, it's just the speed that doesn't exactly cater to power-users. An instantaneous reveal would probably be the best, but reduced motion doesn't do this unfortunately. – Winterflags Sep 21 '16 at 17:43
  • 1
    Same problem here... the mission control animation was instantaneous before I upgraded to Sierra. The defaults write com.apple.dock expose-animation-duration -float 0.1 command does not seem to help. – Olivier Lalonde Oct 11 '16 at 21:23

Adding onto Shelton's answer here: The application BetterTouchTool (paid application, but you get a free trial to start off) allows you to customize trackpad gestures, and it appears that it does not follow the speed of your gestures.

The animation is as fast as it was in El Capitan - or seems that way at least.

I can recommend TotalSpaces2 which can hack newer OS X versions and disable spaces animation. It's paid software but there is free trial: https://totalspaces.binaryage.com

Note: requires disabling System Integrity Protection for installation: https://totalspaces.binaryage.com/sipsettings

I used:

defaults write com.apple.dock expose-animation-duration–float 0

So I just deleted the space between duration and -float, and it looks like it worked actually!

  • Has anyone except the poster tried this? It's been downvoted. – Winterflags Sep 23 '16 at 8:05
  • 1
    @Winterflags No, it's not valid syntax. expose-animation-duration–float isn't a valid key – Alexander Sep 26 '16 at 3:05

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.