1

I have just bought a Macbook 5,1 Unibody Late-2008 (the Macbook which looks like a Macbook Pro).

The seller told me that the WiFi was not working anymore. The Bluetooth isn't working either so I presume the Airport Card is broken.

I have added a USB WiFi adapter and it works correctly, but when I close my laptop it goes into sleep, the light gently fades once, and then the sleep light shines and no more sleep...

I have looked in the pmset logs and found that the computer made DarkWakes but without telling reasons.

If I look in syslog, I see Wake Reason: ?

I have not found anyone experiencing the same behaviour with their computer.

Could the broken Airport card make the computer wakes from sleep?

Can I remove the Airport Card to make it totally disappear from the system? I have seen an iFixit tutorial to change the card but first I would try to disconnect it. Do you think just removing the Camera cable is enough to switch Airport off completely?

I have tried to install several OS from Moutain Lion to El Capitan and the results are the same, the computer doesn't stay on sleep. And now, after two days of work and installations, the computer doesn't want to shut down anymore. Instead, when I choose Shut Down, it restarts ..

I don't know what to do.

Just a small note, the previous owner had replaced the Optical Drive with a 1TB hard drive. The hard drive works correctly.

1

I have seen many forum entries about problems with removing optical drive to put a second hard drive. It seems the camera/airport cable doesn't like that or may be damaged.

In my case, as I said, the Wifi and Bluetooth were not working anymore but the fact that there was a problem with the Airport card probably troubled the OS.

So I decided to unplug the camera/airport cable from the motherboard to completely remove the faulty Airport card.

It is done like that

This solution worked : now, I don't have Wifi/ Bluetooth nor iSight camera, but the computer sleeps perfectly fine and I was able to upgrade OS without any problems and it still sleeps.

So I presume that the faulty Airport card was still sending bad information that made the computer wakes up with no valid reason even with all Wakes' conditions unchecked. I hope that may help other people.

0

Go to System Preferences -> Energy Saver -> Then untick Wake for network access.

This might solve the issue.

Sleep tips: Closing the lid works, but to be safe go to the Apple icon top left, then select sleep, then close lid after everything is off. To keep it awake and make it never sleep, download the Caffeine app. You can select how long you want the computer to be awake.

  • Thanks but it was not enough : Wake for network access was already unchecked. – Fredv Sep 22 '16 at 6:52
  • And when I use Apple / sleep or pmset -g sleepnow, it does exactly the same – Fredv Sep 22 '16 at 6:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .