7

Trying to install the official version of macOS Sierra, released today 2016-09-20.

When I use the Parallels Wizard to create a new VM, I selected the Install macOS Sierra.app application as listed. Next step is saving the OS X image file.dmg file with its default name in a folder I choose. Then I get the error:

Failed to create a bootable disk image file for this version of OS X.

Running Parallels 12.0.2 on a MacBook Pro with El Capitan.

Ironically, I successfully did this same operation with the second, and last, GM seed from Apple using Parallels 12.0.1. Now, a few days later, I cannot install the official Sierra release with Parallels 12.0.2 (.2 update of Parallels is last day or two). So I suppose either (a) Apple changed something with the installer last-minute, or (b) the Parallels company changed something with this week’s new Parallels 12.0.2 update.

  • Follow-up: Installing Sierra from Install macOS Sierra.app with Parallels 12 seems to be randomly successful. I have tried re-downloading the installer from Apple, and tried each released update from Parallels. For each combination sometimes the install succeeds, sometimes it doesn't… must be related the phase of the moon. If it fails one day, try again the next day. – Basil Bourque Nov 17 '16 at 6:06
  • I seem to be able to get it to work in Parallels, but never VirtualBox – Madivad Aug 17 '17 at 16:03
  • @Madivad VirtualBox does not directly support macOS as a guest. You have to do some hacking to get it to work. – Basil Bourque Aug 17 '17 at 16:11
10

I'm use VMware Fusion and just downloaded "Install macOS Sierra.app" from the App Store and then made an ISO Image to install from. The ISO Image should also work in Parallels Desktop.

To create an ISO Image from the "Install macOS Sierra.app" application bundle, I used the following bash script. Note: This requires 12 GB of free space to create but only uses 6 GB when finished.

In Terminal:

touch makeSierraISO
open makeSierraISO
  • Copy and paste the code below into the document, modifying the path to the InstallESD.dmg if necessary, then save and close.

Back in Terminal:

chmod u+x makeSierraISO

To run the script in Terminal: ./makeSierraISO

#!/bin/bash

hdiutil attach "/Applications/Install macOS Sierra.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
hdiutil create -o macOS_Sierra_10.12.0.cdr -size 6144m -layout SPUD -fs HFS+J
hdiutil attach macOS_Sierra_10.12.0.cdr.dmg -noverify -nobrowse -mountpoint /Volumes/iso
asr restore -source /Volumes/esd/BaseSystem.dmg -target /Volumes/iso -noprompt -noverify -erase
rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
cp -rp /Volumes/esd/Packages /Volumes/OS\ X\ Base\ System/System/Installation
cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System/
cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/OS\ X\ Base\ System/
hdiutil detach /Volumes/esd
hdiutil detach /Volumes/OS\ X\ Base\ System
hdiutil convert macOS_Sierra_10.12.0.cdr.dmg -format UDTO -o macOS_Sierra_10.12.0.iso
rm macOS_Sierra_10.12.0.cdr.dmg
mv macOS_Sierra_10.12.0.iso.cdr macOS_Sierra_10.12.0.iso

Assuming you ran the script from your Home Folder in Terminal, then look for the file macOS_Sierra_10.12.0.iso in your Home Folder. Use Parallels to create new VM. Point the new VM wizard to that .iso file. Parallels may complain, saying it is unable to recognize the OS being installed. Proceed and choose macOS from the offered menu.


enter image description here

  • I installed with Virtual Box using the Mac 64-bit option and selected the macOS_Sierra_10.12.0.iso. Before I could install, I had to reformat the Disk .vdi into a Journaled format using Disk Utility (after selecting language). Otherwise there was no disk to select for installation. – Paul Solt Oct 3 '16 at 18:18
  • @Paul Solt, I'm using VMware Fusion and it has a default 40GB HFS+ virtual disk. So it shows when installing, however if I want anything bigger I have to take care of it in Disk Utility before I install OS X/macOS. These directions were really just for creation of the ISO Image, not what's necessary to install it in the different Type 2 Hypervisors. – user3439894 Oct 3 '16 at 19:49
  • These instructions worked perfectly to make .iso file! Thanks so much. I pointed Parallels 12 to the newly-created .iso file, I identified which OS (macOS) and off we went to full normal installation in the usual amount of time (around 10 minutes, not sure). Installing from the .iso solved my underlying problem of Parallels insisting on creating a OS X image file.hdd file of 5 gigs in addition to, and permanently required by, the usual .pvm file. Installing with the .iso worked successfully with no .hdd file created. Again, thanks! Many hours I’ve wasted on other other workarounds. – Basil Bourque Nov 17 '16 at 6:34
  • Is there a way to generalize this to all macOS/OSX installs? – William Mar 21 '17 at 14:20
  • @William, Yes there is and the script I actually use does that. I only posted a handful of hard coded lines to complete the specific task of the OP. I would have liked to post the entire script but it was not commented and I do not like posting a script that has 70+ lines of code that's uncommented. I actually started to add comments and was going to update this answer but never got around to it because I hadn't finished the comments. I'll see if in the next day or so I can make it presentable to post. – user3439894 Mar 21 '17 at 14:47
4

The method posted by @user3439894 worked for me under Parallels.

I did initially have a problem at the first step: + hdiutil attach '/Applications/Install macOS Sierra.app/Contents/SharedSupport/InstallESD.dmg' -noverify -nobrowse -mountpoint /Volumes/esd hdiutil: attach failed - Resource busy

In /Volumes, I unmounted iso and "OS X Install ESD":

cd /Volumes/

amount iso

umount "OS X Install ESD"

Possibly only one of the two mounts above caused the issue, but too late to tell.

Once macOS_Sierra_10.12.0.iso is created, start up Parallels Control Centre:

  1. Choose "Install Windows or another OS from a DVD or image file", continue
  2. Choose "Locate Manually", "Select a file ..." and find macOS_Sierra_10.12.0.iso
  3. Parallels will respond "Unable to detect operating system". Continue, and choose OS X.
  4. Carry on
  • I didn't see iso and umount "OS X Install ESD" did the trick, thanks! – Bob Nov 8 '16 at 21:27
3

I just tested making an ISO of High Sierra 10.13 and creating a Parallels VM using it and had success. I tried using the 10.13 updated script that @cobberboy posted, which worked to create the ISO, but after booting to it in Parallels and attempting to start the macOS install it would throw an error about a .mpkg file missing.

So I used the following method instead:

First download the "Install macOS High Sierra.app" from the App Store, it should land in the Applications folder.

Then open Terminal and run each of these commands in order:

hdiutil create -o /tmp/HighSierra.cdr -size 5200m -layout SPUD -fs HFS+J

hdiutil attach /tmp/HighSierra.cdr.dmg -noverify -mountpoint /Volumes/install_build

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/install_build

(the above command may come back with "To continue we need to erase the volume at /Volumes/install_build. If you wish to continue type (Y) then press return". If so enter Y)

mv /tmp/HighSierra.cdr.dmg ~/Desktop/InstallSystem.dmg

hdiutil detach /Volumes/Install\ macOS\ High\ Sierra

hdiutil convert ~/Desktop/InstallSystem.dmg -format UDTO -o ~/Desktop/HighSierra.iso

A file named "HighSierra.iso.cdr" will now be on the Desktop, rename it to only use the .iso extension (remove .cdr).

Open Parallels and choose "Install Windows or another OS from a DVD or image file."

Drag the "HighSierra.iso" file into the window (or locate ISO file manually).

Parallels will respond with "Unable to detect operating system". Click continue to ignore this and proceed with the install through Parallels.

2

@user3439894's method worked for me too to create an iso. For High Sierra (10.13) , it looks like they've moved the BaseSystem.dmg out of the InstallESD.dmg so I had to modify the script a little:

#!/bin/bash

hdiutil attach "/Applications/Install macOS High Sierra.app/Contents/SharedSupport/InstallESD.dmg" -noverify -nobrowse -mountpoint /Volumes/esd
hdiutil create -o macOS_HighSierra_10.13.0.cdr -size 6144m -layout SPUD -fs HFS+J
hdiutil attach macOS_HighSierra_10.13.0.cdr.dmg -noverify -nobrowse -mountpoint /Volumes/iso
asr restore -source "/Applications/Install macOS High Sierra.app/Contents/SharedSupport/BaseSystem.dmg" -target /Volumes/iso -noprompt -noverify -erase
rm /Volumes/OS\ X\ Base\ System/System/Installation/Packages
cp -rp /Volumes/esd/Packages /Volumes/OS\ X\ Base\ System/System/Installation
cp -rp /Volumes/esd/BaseSystem.chunklist /Volumes/OS\ X\ Base\ System/
cp -rp /Volumes/esd/BaseSystem.dmg /Volumes/OS\ X\ Base\ System/
hdiutil detach /Volumes/esd
hdiutil detach /Volumes/OS\ X\ Base\ System
hdiutil convert macOS_HighSierra_10.13.0.cdr.dmg -format UDTO -o macOS_HighSierra_10.13.0.iso
rm macOS_HighSierra_10.13.0.cdr.dmg
mv macOS_HighSierra_10.13.0.iso.cdr macOS_HighSierra_10.13.0.iso

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .