2

I'm using Airfoil as a way to broadcast my iMac as an AirPlay device on my home network. This utility does, besides creating an "Airfoil" server, also create an actual AirPlay device that can be seen under System Settings > Sound and by Opt–clicking the Sound/Volume icon in the OS X menu bar.

For some reason, the Airfoil AirPlay device (reachable in the below menu) has suddenly stopped working. When trying to send audio to it from my other Mac, I get the system pop-up "Could not connect to xxx-Airfoil".

enter image description here
(Ignore the current checkmarks in this image. It's the "Airfoil" AirPlay device I'm trying to access)


However, when using the Airfoil application menu directly to access the computer via the Airfoil service (not AirPlay in the audio output tab), audio transmission works as intended. So my conclusion is that there is something wrong with what/how OS X "knows" about the AirPlay device.

Question: Is there a way to get OS X to "reindex"/reinstall the available Airplay Devices?

Something like (in pseudo-terminal command):

airplayutil --reindex devices

I've tried reinstalling Airfoil and its sister-application Airfoil Satellite, and also tried rebooting the computers. Not sure why it suddently has stopped working – I'm still on El Capitan.

1

Typically when I see issues with AirPlay, particularly when you've taken the troubleshooting steps that you have already, it is a network issue and not a software issue.

So here are a few things to try/verify:

  1. Can you AirPlay from this Mac to other AirPlay receivers?
  2. Are you on the same physical network as the AirFoil receiver (including same Wi-Fi network—and the same frequency band (2.4 GHz vs. 5 GHz)?
  3. Is Bonjour working?
  4. Are all multicast filtering options disabled on your switch/router (or conversely, is multicast traffic permitted)? Note that if your router autoupdates, a setting or default may have changed.
  5. Have you tried temporarily disabling all firewalls on both machines?
  • Thanks, for some strange reason it was playing for a few minutes before it disconnected. So you're probably right that it may be a connectivity issue. – Winterflags Sep 23 '16 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .