1

After updating to iOS 10, most of the songs in my library that I could play before now won't sync and the error message I get is

Some of the items in the iTunes library, including "Song name", were not copied to the iPhone "iPhone name" because they cannot be played on this iPhone.

But I could play these items before, nothing has changed.

When I check the media format of one of the items it just says:

  • kind: MPEG audio file
  • bit rate: 320 kbps
  • sample rate: 44.100 kHz
  • channels: Joint stereo
  • encoded with: LAME3.99
  • format: MPEG-1, Layer 3

From what I know this is just an MP3 with constant bitrate, a format that the iphone did support one week ago...

2

This sounds dumb, but play the affected songs on itunes and resync. It should work.

  • 1
    That sounds smart to me, isolating the issue by using another app and making sure that this other app can’t cache or correct the song entry in whatever database tracks the list of songs available. – bmike Mar 26 at 11:06
1

I tried gnzlbg's solution and it didn't work for me. So I powered off the iPhone and restarted. It still didn't work, perhaps because I still had the phone connected to my computer. I disconnected, power cycled again, and now it works.

0

I disabled iCloud Music, Music Match, and all that stuff from the iphone, turned it off, turned it back on again, and now everything syncs fine...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .