On my devices I see two separate conversations. One goes to her phone and one goes to her Mac. I can't see which is which but she has only one phone number and one iCloud account. What is causing this and how to fix?


On her iPhone and iPad both, she will need to go to the Settings App > Messages > Send & Receive. Then make sure to select her phone number on her iPad, and her associated iCloud emails on her phone. For the least amount of confusion, the selections should match.

You can configure FaceTime the same way.

  • 1
    Right! So, her iPhone settings were connected only to her phone number. I had to associate it to an iCloud account by specifying her email again even though she was already connected to iCloud on this device. – Nic Cottrell Sep 20 '16 at 15:01
  • I have seen my wife's iPhone do this—actually, it happened with her update to iOS 10. For some reason, one email address on her phone got deselected, and her phone number got disconnected on her iPad. ¯_(ツ)_/¯ – samh Sep 20 '16 at 15:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .