1

After a fresh install of macOS Sierra, I installed the macTex distribution without any GUI programs. After that, I installed the latest release of the Tex Live Utility to update my tex distribution via a nice GUI. However, I cannot start the Tex Live Utility because macOS complains about that the program has not been signed by a verified developer. After I tried opening, there is a button under System -> Security to open the program anyway, but I keep going to see the same error message. This worked with another piece of software but with Tex Live Utility, this approach fails. Any idea on how to solve it?

  • You can also try changing that setting to the least restrictive ("Anywhere"? I can't remember exactly what it says) temporarily, opening the program as normal and then reenabling the setting. After a programs runs for the first time, that setting no longer affects execution of it. – tubedogg Sep 20 '16 at 4:50
  • The least restrictive is "App Store and verified Developers". Before Sierra, there was a third option which was basically "Install what you want". This is not there any more... – DaPhil Sep 20 '16 at 8:52
  • Two possible things to try in the answers to this question. – tubedogg Sep 20 '16 at 15:29
  • Also see tug.org/mactex/sierra.html – nohillside Dec 2 '16 at 20:49
2

They have released a fixed version. You can update to the newest Tex Live Utility from the command line tlmgr update --self

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .