0

Whenever I get a WhatsApp message with my iPhone locked, I can't see sender's nickname as set by them in their WhatsApp profile. I used to see it previously, but now I see the name which I have saved the contact with in my Contacts list. I would like to get back the ability to see nickname instead of contact name. I don't want to delete the name in my contact list I just want it to be like it was previously.

How can I do this?

1

Had this same problem and got the below reply from whatsapp support

To turn on previews that display the contact name but not message:

Go to WhatsApp > Settings > Notifications > turn Show Preview on. Go to iPhone Settings > Notifications > WhatsApp > Show Previews > Never.

  • Thanks kara dua. But why my friends get the notifications and it say message but me it say notifictions? Its so confusing. – Sara May 20 '18 at 6:38
  • They might not have updated their whatsapp. It was message before, for me as well. It has something to do with notification management on iOS 11. Good thing that has happened because of this is, now if a person sends you 10 messages, it is shown under one notification only with the number of messages sent unlike before where ten different notifications were created. – Karan Dua May 21 '18 at 1:59
0

have you checked your privacy settings? just make it sure that WhatsApp have access to your contacts. to do so just go to Settings > Privacy > Contacts and allow the WhatsApp to access your phone's contacts

You must log in to answer this question.

protected by Community May 23 '18 at 21:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .