I had a few apps originally purchased through the App Store that got corrupted. I removed them with the intent of re-installing them from the App Store, but it seems that the App Store thinks they're still/already installed. The action button is disabled. I found How can I reinstall an application that the Mac App Store thinks is installed already? but the solution reported there didn't work for me.

The app doesn't exist in either /Applications or /Downloads. Do you have any idea about what I might be able to do to re-download the app?

3 Answers 3


Try the following steps in order:

  1. Quit the App Store
  2. Eject all disks (including any .dmg files you have mounted)
  3. Use Spotlight to search your hard drive for anything with a similar name to your application.
  4. If you find anything related to the application in question remove those files.
  5. Delete the file at ~/Library/Preferences/com.apple.appstore.plist
  6. Delete the file at ~/Library/Caches/com.apple.appstore/Cache.db
  7. Delete the file at ~/Library/Cookies/com.apple.appstore.plist
  8. Delete the file at ~/Library/Cookies/Cookies.plist
  9. Open terminal and run this command: /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user
  10. Logout of your computer & log back in
  11. Reopen the Mac App Store
  12. Try to install the application again.
  • 4
    Thanks. The apps were "hidden" on a second internal drive that I didn't expect to be picked up. Thanks for getting me there. Sep 19, 2011 at 11:17
  • 1
    This is an amazing answer, but the irony is that none of the steps solved it, but the unchecked answers below did the trick.
    – Stephen J
    Nov 25, 2013 at 23:51
  • 1
    killall Finder did the trick for me.
    – Manav
    Jan 26, 2015 at 3:42

It sounds like you have a backup drive attached. The easiest thing is to add the backup drive to the ignored list in Spotlight preferences.


Might it be possible that you have some other version or backup copy on another volume lying around? I've read about people having the Beta of Reeder on another volume and that blocked the App Store. This person solved it by unmounting that volume while installing from the MAS. (found the source: http://reverttosaved.com/2011/06/09/mac-app-store-a-newer-version-of-this-app-is-already-installed-on-this-computer/)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .