1

I'm trying to set up 2FA on my iCloud account but I get this message:

enter image description here

Any ideas on a solution? There's also no option in the security settings on my iPhone to enable it. I'm running the latest versions of iOS and macOS.

  • Where you running a beta OS on either devices prior to updating to the latest versions? I've seen people have problems if they where running a beta. Also, try changing your Apple ID security questions and make sure you have a credit card on your account (Apple uses that to verify identity). – fsb Sep 18 '16 at 14:25
  • Is the option available to you at id.apple.com? Do you have any old devices listed there? – user11633 Sep 18 '16 at 15:14
1

Had the same issue.

In my case I apparently missed/junked/deleted the verification email sent to me by Apple. A call into support and they resent the email and I was good to go.

Before you call a quick search of your email for appleid@id.apple.com might save you some time.

Hope this helps.

-1

If you have enabled two-step-verification you need to disable it first. Go to your AppleID website, login and edit the security section. Disable the two-step-verification.

If you're ready with that, you can try to enable the two-factor-authentication on your device.

AppleID Website: https://appleid.apple.com/#!&page=signin

  • The OP states he's running the latest OS versions on both Mac and iPhone so how does this answer the question? – fsb Sep 18 '16 at 14:16
  • misreading the OP's questions :( . I've correct my answer. – dante12 Sep 18 '16 at 15:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .