1

Notice: This is not a duplicate! Other questions had to do with older versions of OS X or had to do with temporarily disabling resume.

El Capitan has made my iMac very, very slow. A hard reboot should clean the slate so I can recover from OS hangs, but now windows and programs that were open when I shut the iMac down (with the power button) are restored to their previous states.

How can I disable this completely? I do NOT want to have to select a button every time I shutdown/restart, which is something I cannot do if I use the hardware reset.

  • When you turn the system off by holding the power button (which I believe is what you are describing as a "hard reboot") it should pop up after the reboot and say something to the effect of, your system was shut down irregularly, and do you want to restore your open programs. Does it not do that? – tubedogg Sep 18 '16 at 1:31
  • @tubedogg I don't want that at all. – Melab Sep 22 '16 at 13:07
  • I just want to tell you that I've seen multiple old macs become significantly faster on Sierra, and especially High Sierra. This may not be relevant to you but these computers were unusable in the versions before. – Ezekiel Elin Oct 19 '18 at 3:07
1

There is a simple method for this, for anyone using Lion+.

Navigate to /username/Library

Cannot see Library Folder: While in Finder > Press and Hold OPT key Down > under GO Menu> Select Library

Once there, you will see a folder named Saved Application State

To disable ALL resume states,

  1. right-click on Saved Application State > Get info
  2. select Locked checkbox

To disable SOME resume states

  1. right-click on Saved Application State/Sub-Folder Name > Get info
  2. select Locked checkbox

enter image description here

enter image description here

That's it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .