101

A few releases ago OS X introduced scroll acceleration, which means if you keep scrolling in some direction, the speed of the scroll will be greater and greater. You cannot disable this from the UI. It is extremely annoying if you want to scroll through a long website or a long source code in an editor.

Until macOS Sierra you could disable this using DisableExtremeScrollAcceleration tool. But this tool is no longer working.

Is there any way to prevent the scroll acceleration?

5
  • 1
    ...& I've been loving accelerated scroll for years, can't live without it - proves nothing but horses for courses, I guess;-) SteerMouse can adjust scrolling behaviour amongst other things, depending on the mouse you use [there's a v5 currently in beta, a bit buggy but free for a while, so you can judge for yourself]
    – Tetsujin
    Commented Sep 17, 2016 at 18:27
  • 3
    I really hate it... have you tried scrolling a large list in a small 200px heigh container??? I'm going to train inner peace, focus and control with solitary monks for 10 years in order to scroll down 10 lines without wobbling the mouse wheel all the time!
    – DerpyNerd
    Commented Apr 26, 2017 at 8:49
  • System Preferences -> Accessibility -> Pointer Control -> Disable: Spring-loading delay Commented Nov 14, 2022 at 10:12
  • No, spring loading means dragging something over an element which can be expanded (like a folder), and waiting until it expands.
    – gklka
    Commented Nov 15, 2022 at 11:08
  • 2
    I don't have enough rep to answer, but I found "Mac Mouse Fix" on a post on Reddit. It's free and works well for me, scrolling feels much more natural. mousefix.org reddit.com/r/MacOS/comments/p9vqhu/comment/ha0o3rn/…
    – TheHud
    Commented Jan 12, 2023 at 9:09

10 Answers 10

106

I wrote a small program to fix this behavior: https://github.com/emreyolcu/discrete-scroll

You may download a binary here. It runs in the background and allows you to scroll 3 lines with each tick of the wheel.

18
  • 4
    Thanks! For 2 days I was trying every piece of software but your small utility saved the day!
    – hambos22
    Commented Dec 3, 2016 at 11:58
  • 1
    Thanks for this, I feel like Yosemite had some amount of inertia still but it sure beats it not doing anything for a "click or two" of the mousewheel. Oh Apple. Commented Dec 5, 2016 at 21:11
  • 1
    Download SmoothScroll if you also want a smooth animated scrolling experience with your mouse wheel (you can also disable the acceleration or change it to your own liking)
    – gblazex
    Commented Dec 14, 2016 at 10:44
  • 18
    @Emre-Yolcu Thank god. It's pathetic that I have to download a whole set of little scripts just to make simple things like this work properly. Commented Jan 19, 2017 at 16:18
  • 7
    @orrd Yes, it does need to be run each time you boot. If you want this to be automatic you may go to System Preferences > Users & Groups > Login Items and add DiscreteScroll to the list. If you want to undo the effect you may launch Activity Monitor, search for DiscreteScroll and force it to quit. I am planning to write a preference pane out of this program to make these operations more intuitive and include configuration options.
    – Emre Yolcu
    Commented May 10, 2017 at 22:09
45
+150

After many years of frustration with macOS & wheel mice, I've developed Smooze. You can use this app free for disabling acceleration ( you would only pay to use other features of the app)

  • toggle the "Animate Scroll" to Off and you're good to go.

enter image description here

Smooze website

16
  • @Winterflags What's the mouse model? I've tested it on several Logitech mice including MX Master, Performance Mouse MX and some other cheaper modals without any issues without LCC installed. This issue was also never reported to me by the Smooze users. You should try to update LLC or better yet, remove it completely.
    – Segev
    Commented Apr 3, 2017 at 11:59
  • 1
    @Winterflags It might be a problem with Sierra. Earlier versions had a bug that effected scrolling & Logitech mice. I'm currently on 10.12.3 with the same mouse, LLC not installed & Smooze installed and everything is working as it should.
    – Segev
    Commented Apr 3, 2017 at 12:09
  • 4
    THANK YOU. This is exactly what I was looking for. The default scroll wheel behavior drives me ABSOLUTELY INSANE on OSX, and I had given up on ever getting it to work as intended. This is going into my must-have tweak build for every version of macOS I run.
    – Gavin
    Commented Apr 17, 2018 at 22:40
  • 1
    Weird..keyboard can't be disabled by Smooze. Anyway, removing Accessibility permission (while the app is running) is fixed in version 1.7.3 I just released.
    – Segev
    Commented Jun 24, 2019 at 17:28
  • 1
    @Tauri28 it's just you.
    – Segev
    Commented Jun 16, 2022 at 17:43
19

Here's what I've found, so far it seems kinda working:

http://dolphm.com/disable-mouse-pointer-acceleration-and-scroll-wheel-acceleration-in-os-x/

Type into the Terminal:

defaults write .GlobalPreferences com.apple.scrollwheel.scaling -1

Then relogin.

7
  • 1
    What is the default value and how do I revert if I no longer want this change?
    – wenbert
    Commented Oct 10, 2016 at 19:07
  • 1
    You can always delete it with defaults delete.
    – gklka
    Commented Oct 10, 2016 at 19:09
  • This doesn't work even after login. The sensitivity of the affected app is still too high compared to the unaffected ones.
    – wenbert
    Commented Oct 10, 2016 at 19:16
  • 2
    This seems to have worked for me possibly in combination with disabling inertia and acceleration re the settings app paths given in other answers. Unchecking "Spring-loading delay" in the same settings area may also have done it. Commented Jul 18, 2017 at 15:55
  • @wenbert defaults read .GlobalPreferences com.apple.scrollwheel.scaling gives me 0.75. Commented Dec 15, 2020 at 22:32
8

System Preferences>Accessibility>Mouse & Trackpad>Trackpad Options>Scrolling>Without Inertia

5
  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions
    – Allan
    Commented Oct 7, 2016 at 0:46
  • 14
    The question was about scroll acceleration not interia. They are different things.
    – gklka
    Commented Oct 7, 2016 at 7:57
  • 15
    That option is not available if you use a mouse. Commented Nov 12, 2016 at 23:20
  • Does this option no longer exist? Commented Sep 30, 2021 at 23:42
  • The option still exists, but it doesn't prevent the distance scrolled from being affected by the speed of scroll wheel movement. Commented May 6 at 17:06
6

Try USB Overdrive. I was having the same problem as you and this fixed it. It works with MacOS Sierra.

Credit to this post

2
  • 2
    Welcome to Ask Different. Please provide more information about what USB Overdrive does to resolve the issue, like what settings need to be set, etc., so the answer is more useful.
    – tubedogg
    Commented Sep 21, 2016 at 2:17
  • Thanks! I had scroll wheel issue after upgrading to macOS Sierra. I just installed the USB Overdrive (without any settings). And, my logitech wireless mouse just works on macOS Sierra as before ! Commented Sep 22, 2016 at 14:20
5

I don't have the rep to upvote or comment on Sky D's post, but it was spot on:

For trackpad: System Preferences>Accessibility>Mouse & Trackpad>Trackpad Options>Scrolling>Without Inertia

For mouse: System Preferences>Accessibility>Mouse & Trackpad>Mouse Options>Scrolling>Without Inertia

Inertia in images

3
  • 10
    No, I've already said multiple times, that scroll interia and scroll acceleration are two different things. The first one is responsible for scrolling and decelerating the content when you lifted your fingers from the touchpad/Magic Mouse and the latter one accelerates the scroll speed when you keep scrolling in a given direction.
    – gklka
    Commented Oct 13, 2016 at 13:26
  • 2
    I have a feeling this scrolling interia dropdown no longer exists with certain mouse vendors since Yosemite. My G400s does not have this so I had to use the "discrete scroll" application as mentioned in another answer. Commented Dec 5, 2016 at 21:13
  • 4
    There's no inertia dropdown in my Sierra 10.12.5 (Logitech G600).
    – JavaRunner
    Commented Aug 15, 2017 at 1:13
3

macOS Sierra introduced a scroll wheel deadzone where input would be ignored unless you scrolled at a minimum speed. Scrolling the wheel one notch at a time would not produce any movement on the screen. This deadzone made people scroll the wheel faster than before, thus hitting the acceleration threshold even faster (though it's always been there). The scroll wheel deadzone has been removed in the 10.12.2 public betas.

With defaults write .GlobalPreferences com.apple.scrollwheel.scaling -1, there should be no scroll wheel acceleration in apps (that use native scrolling).

3
  • 1
    I replied to the wrong question. I've updated my answer to be relevant anyway.
    – Monstieur
    Commented Dec 9, 2016 at 15:29
  • This did not work for me: macbook pro 2016, sierra, deathadder chroma, safari, chrome
    – Baz
    Commented Dec 14, 2016 at 21:25
  • This is a duplicate to @gklka's answer. Commented Jul 18, 2017 at 15:54
2

I found the "fix" for my Logitech mouse.

  1. System Preferences
  2. Control Center (available when you install Logitech control center)
  3. Select your mouse and click "configure".
  4. Select mouse wheel.
  5. On the bottom, there is a "acceleration" label with a slider. Set it to "null" or "max" (I can't see the difference.)

I also had an issue with my back/forward buttons. Within the same control panel, I had to reconfigure them as "key strokes" of "cmd + left arrow" and "cmd + right arrow".

Edit: Logitech released an updated version of their control center, which fixes the issue.

1
  • I had the problem with my Logitech M585, I tried everything in all the answers but to no avail. Turns out all I had to do was open Logi Options, go to Point & Scroll, then set the scrolling speed to minimum. It finally removed acceleration for good.
    – AgentRev
    Commented Nov 25, 2021 at 22:10
0

Alternatively you can use SteerMouse. I've been using this for a few years. It costs $20, but for me it was worth it. Default mouse acceleration settings always annoy me.

Anyway, after install:

  1. Open it up via System Preferences -> SteerMouse.
  2. Select the 'Scroll' tab.
  3. Click 'Roll Up, and in the next dialog choose Mode = Linear.
  4. Do the same for 'Roll Down'.

Pics below:

Scroll Tab

Roll Up Dialog

1
  • 1
    Thanks for the idea, but I don't really want to give up smooth scrolling for disabling scroll acceleration. As I can understand, SteerMouse does scrolling by emulating cursor keys.
    – gklka
    Commented Oct 7, 2016 at 7:58
0

I made Mac Mouse Fix.

At the time of writing, the app does not let you turn off scroll acceleration entirely, but it makes scrolling feel very easy to control by adding animations and improving/reducing the acceleration effect.

It's also open source, lightweight, and easy to use, while bringing many other nice improvements to your mouse experience.

Download | GitHub


Pricing model

  • Mac Mouse Fix 2
    100% free, and I plan to keep supporting it.
    Download
  • The latest version of Mac Mouse Fix
    Free for 30 days, costs a few dollars to own.
    Download

Thanks for your support!


Screenshot of Mac Mouse Fix version 3 ^

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .