0

I have autohide enabled for my dock and it seems to be a feature (at least in OS X 10.11.6) that, when I drag my mouse to the bottom of the screen when on a full-screened program, the dock will not display until I have attempted to drag the mouse down at least another time.

This problem does not occur when I am not on a full-screened program; the dock displays instantly.

I'd like my Mac to have the functionality of displaying the dock as if I was not ever in full screen mode.

Edit: If it is important, I use HyperDock. A change to this also would be sufficient for me; I have a license.

  • I can sort of repro on the first attempt after full-screening, but if I wait approximately double the normal length of time, it works every time. Subsequent attempts revert to normal. – Tetsujin Sep 16 '16 at 14:20
  • My aim is to have the dock act as usual the first time however. – Alex W Sep 16 '16 at 14:36
1

Completely remove or minimize HyperDock delay

How to auto hide the dock and remove its delay on the Mac

  1. Open Terminal
  2. Copy and paste the following command into a Terminal window:

==UPDATED CODES==

defaults write com.apple.Dock autohide-delay -float 0 && killall Dock

To restore the default behavior, enter:

defaults delete com.apple.Dock autohide-delay && killall Dock

If you don't want to remove the delay altogether, but just want to shorten it, you can play around with the number after the -float option. For me, this is a good fit:

defaults write com.apple.Dock autohide-delay -float 0.05 && killall Dock
  • 1
    This improves the situation but does not achieve the desired outcome; whereas this removes the animation for the dock to appear, the dock appearance still is more difficult to activate when on a fullscreen program. My problem is primarily with the amount I need to drag the mouse to the bottom of the screen occasionally to activate the dock's appearance as opposed to the time it takes to appear once it's started appearing. – Alex W Sep 16 '16 at 16:11
  • Removing animation in turns removes delay in autohide / autoshow. Seems HyperDock did not allow it to override. – norcal johnny Sep 16 '16 at 16:33
  • @AlexW Please see update in answer. This is confirmed to be working. – norcal johnny Sep 16 '16 at 17:09
  • It doesn't remove the delay in autohide/autoshow when in fullscreen mode however, only when in non-fullscreen mode. The heart of my problem is the discrepancy in how the dock behaves when in fullscreen compared to when it is not. If there was no discrepancy, your answer would instead be ideal. However, as there is, I still have to move my mouse to the bottom of the screen and then move it further and further down to have the dock display when in fullscreen, – Alex W Sep 16 '16 at 17:28
  • Interesting as this is confirmed by many users to make the dock instantly snap on fullscreen when cursor is placed over the bottom. – norcal johnny Sep 16 '16 at 17:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .