0

few days ago I wanted to split partition but obviously I can't read and I chose "partitionDisk" option, basically I did:

diskutil partitionDisk /dev/disk1 GPT JHFS+ New 100g

That was a mistake. It didn't ask me anything about erasing data, but still its terminal so I don't blame it. Now I've got an empty partition, but I want to recover the old one.

Is there any way to to such thing? I tried with testdisk, but it's kinda hard to use this soft, tried also deeper search, I saw there about 100 of rows with multiple partitions, but couldn't preview any because of HFS+ I guess.

However I believe the last option would be to use Photorec and recover files one by one...

Is someone could help I would be grateful.

1

You could email tech support for Photorec (and others) to see if they can recover from this particular situation. If they say no then your only recourse is a data recovery specialist like OnTrack.

Generally formatting/partitioning a drive does not wipe the data just the partition map and catalog, so it is possible that this might be recoverable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .