I have Mac OS X El Capitan 10.11.6, iMac 27 inch late 2013. I can print any PDF but nothing else. In the print dialog box where I can normally see what I am about to print, it is blank. If I do print I get a blank sheet. If I save to PDF, you get a blank PDF except for a tiny box in the middle.

I have removed and reinstalled the print drivers. I have tried the Command+Option+P+R keypresses at startup.

  • Can you please add a screenshot of the print dialog? Also, does it happen in all applications or only in one?
    – nohillside
    Sep 16, 2016 at 8:22
  • I would add a screenshot but that suggestion to reset CUPS worked. THANK YOU. Sep 16, 2016 at 21:33

1 Answer 1


Try resettings CUPS (Common Unix Printing System). To do this right click on the printer in System Preferences and select Reset Printing System. You will need to re-install the printer afterwards but this can fix weird printing issues like the one you describe.

  • YES, that worked. Thank you so much. I'm really glad to know about resetting CUPS. Sep 16, 2016 at 21:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .