6

I want to enable Tap-to-click for my trackpad on the login screen of my MacBook Pro with El Capitan 10.11.6 (15G1004).

I tried everything proposed on this old question but nothing has worked.

Could you help me please?

1

I just tried this and it worked on Sierra but should work on older versions too... The internal trackpad uses a different driver (USB) so need to enable a different default

sudo defaults write com.apple.AppleMultitouchTrackpad Clicking 1

0

Type the following in the terminal and reboot device after that.

defaults write com.apple.driver.AppleBluetoothMultitouch.trackpad Clicking -bool true
defaults -currentHost write NSGlobalDomain com.apple.mouse.tapBehavior -int 1
defaults write NSGlobalDomain com.apple.mouse.tapBehavior -int 1

I've tested them on my Macbook Pro 15" 2015 running 10.11.6

Source: https://github.com/mathiasbynens/dotfiles/blob/master/.macos

Mathias Bynens posted a similar question a few years ago. He wrote the above file on Github.

  • I just tested the first on my MBP13" 2010 running 10.11.6 and using user switching to get to the login window do not see tap-to-click working. Does it require a restart or logging out or something like that? – j-beda Sep 15 '16 at 20:10
  • Sorry, for the missing information. It requires a logout. – varunyellina Sep 16 '16 at 3:14
  • Thank you @varunyellina, but unfortunately it's not working for me. :( Is there something I can check to figure out where is the problem? Is that command meant to edit any configuration file on the system? – Brutus Sep 16 '16 at 7:53
  • They did work for me. Just to confirm, I did further testing and they don't seem to be very reliable. I'll update the answer with proper results. – varunyellina Sep 16 '16 at 8:49
  • Neither this is working for me (the updated answer with the Bynens code)... :( – Brutus Sep 16 '16 at 9:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .