3

At some point or another, I bought some albums on iTunes. In some cases, I've also ripped these CDs and imported them into iTunes. In older versions of iOS, I could hide purchased music from the Music app, but now that purchased music shows up, leading to duplicates like this:

Duplicate tracks

Is there a way to hide purchased music in iOS 10?

-1

Yes you can, using iTunes (make sure it is the latest 12.5 or newer version) click Library > Songs. Make sure you have the cloud icon column revealed and click View and make sure All Music is checked.

You should see all the music available to you for download to your local machine. Click the cloud icon to sort, select all the cloud songs, and delete. This essentially hides them from your view, until you go into Store > Purchased to view your history of songs you've bought in the past.

When you go into Music on your iPhone it should remove all those pesky cloud icon songs

I found this article, which helped me: https://www.igeeksblog.com/delete-hide-purchased-music-on-iphone-ipad/

2

This Apple Support page describes how to hide/unhide purchased music.

Hide your purchases

You can hide music, movies, TV shows and apps in iTunes on your Mac or PC. You can hide books in iBooks on a Mac or iTunes for Windows on a PC.

To hide purchases on an Apple TV, use the iTunes steps.

You can hide apps in the App Store on an iPhone, iPad, or iPod touch if you use Family Sharing.

In iTunes

  1. Open iTunes.
  2. If you’re not signed in, sign in with your Apple ID.
  3. From the menu bar at the top of your computer screen or at the top of the iTunes window, choose Account > Purchased. If you use Family Sharing, choose Account > Family Purchases.

    If you’re using Windows and can’t see the menu bar, learn how to turn it on. Depending on what you want to hide, click Music, Movies, TV Shows, Apps, or Audiobooks at the top of the window, then click All. All of your purchased items appear.

  4. Scroll to find the item that you want to hide. Hold your pointer over the item and look for the x icon in the upper-left corner. Click the icon.

  5. When prompted to confirm that you want to hide the item, click Hide. The item hides.

0

I've tried everything...disabling apple music and manually deleting purchased playlist that apple decided to put back on. Only solution I found is to log out of itunes.

-2

any of above ways doesnt work for me. The only solution for me is just sign out your itunes account in you iphone (settings > itunes & app > tap your account then sign out

  • Welcome to Ask Different, Please elaborate your answer a bit more. – killswitch Oct 23 '16 at 7:24
-2

The only thing that works in ios 10 is to log out of itunes store account and match, then use a computer to sync everything. I much preferred being able to log into match, DL the tracks I wanted to hear, then turn match off so the car stereo and other usb devices would only see the downloaded files. This ios version is an absolute calamity for music playout. Ripping cds is actually easier and cheaper than using the store now.

  • Welcome to Ask Different! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post once you have sufficient reputation. If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Tetsujin Dec 8 '16 at 7:46

You must log in to answer this question.

protected by bmike Dec 8 '16 at 15:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .