2

For some reason, I cannot get "Auto Unlock" to work.

Currently running macOS Sierra GM on a MBP Retina Early 2013, watchOS 3.0 and iOS 10 GM.

I've already disabled Two-Step verification and enabled Two-Factor verification for my Apple ID. All devices appear registered on iCloud devices.

Any ideas of what could be the reason?

2

As mentioned in other answers, the auto unlock feature is officially supported only on Macs that were introduced after mid 2013, and include both Bluetooth 4.0 and 802.11ac. As an owner of a 2012 retina MacBookPro, I was disappointed to find that the feature did't work.

However, it is pretty easy to replace the older Airport chip with a newer one that is used on mid 2013 models (model number of the chip: BCM94360CSAX, can be found on eBay etc for around $10 or so). After replacing the chip, the option for auto unlock appears on the preferences and you should be good to go (for me, required also nvram reset and logout from iCloud). Obviously the operation voids warranty, and some have reported it to cause issues on OS X recovery install over wifi. Still, it seems to be currently the only option for enabling the feature, and as an added bonus you get also the better transfer speeds of an 802.11ac chip.

1

It's not a hardware limitation if you have Bluetooth 4.0, you can see it in apple>About this Mac > System Information > bluetooth > LMP Version

They just used the easy way to enable or disable the feature if model greater than 2012 it's enabled otherwise not, despite having the correct hardware.

  • Thank you for your comment. System information reports LMP Versión: 4.0 (0x6). So it seems that my model should be compatible. Still does not work. – Cristian Meneses Sep 14 '16 at 3:50
  • I have a "MacBook Pro (Retina, 13-inch, Early 2013)" and the option is not available. It has Bluetooth 5.0.0f18 + LTE – Ade Sep 24 '16 at 20:34
1

Ok, so first of all, thanks for all your inputs.

It seems like there is no official way to enable Auto Unlock on my MBP.

As I can read on the How to upgrade section of Apple macOS page, it says

enter image description here

As my Mac is an early 2013 model, it seems like is not supported by this feature.

In case of any doubts, I've already done the following

  1. Enable Two-Factor Authentication on all my iCloud devices
  2. Installed macOS Sierra on my MBP (clean install)
  3. Installed iOS 10 on my iPhone 6 Plus (clean install)
  4. Installed watchOS 3 on my Apple Watch
  5. All my devices are listed under "Trusted devices" on iCloud
  6. Handoff and Universal clipboard are working between devices.

Anyways, I'm looking at Continuity Activation Tool , maybe they can release a newer version that fully supports macOS Sierra and enable it somehow.

1

The feature appears to require not only Bluetooth 4 but 802.11ac. Ostensibly this is because 802.11ac time of flight calculations are used to estimate the distance to the watch. (EDIT: It's not actually 802.11ac but 802.11v, but you need the newer network card to support 802.11v, see below.)

I feel for you, as I too cannot get my "Macbook Pro (Retina, 15-Inch, Early 2013)" to enable Auto Unlock. It's kind of frustrating that they state you need a model newer than 2013, when it's really a model newer than "early 2013."

EDIT: I agree that requiring AC doesn't seem to make much sense, since the watch itself isn't 802.11ac, but it seems to be true. Newer official content by Apple now state "mid-2013" instead of "early-2013" as the cutoff.

This blog post describes the process by which upgrading the network card to an 802.11ac card (BCM94360CSAX) enables the feature. Unfortunately, the complete instructions to upgrade your MBP by Mark Bingley are at a currently-broken link on another blog, though maybe this link will come back in the future.

Others have reported success after upgrading the wireless in an early 2013 MBP, and even a 2010 Mac Pro (apparently after installing a new wifi/BT4 card).

EDIT 2: Oh, and here's this for a "link to a reputable site" site that explains it. Apparently you need a modern network adapter to get 802.11v support (yes, v), which is used to measure network latency; in this case it is used to measure the lightspeed roundtrip time-of-flight to the Apple Watch to ensure you are within 3 meters for auto unlock.

Neither the Apple Watch nor the MBP use 802.11ac at all to communicate. The issue is that older network cards in Mac hardware prior to the mid-2013 MBPs (specifically BCM43xx adapters) do not support the 802.11v timestamp field. Or so that article states.

  • That doesn't seem to be correct, or even logical. Please add some links to reputable sites that list this as a requirement. It shouldn't matter to the watch or the Mac what my wireless speed is. What if I'm outside in a park with no wifi? – fsb Sep 21 '16 at 21:00
  • I understand the time-of-flight part, but wouldn't WATCH also need to communicate over 802.11ac for that? As far as I know, WATCH only includes a 2.4 GHz radio. – user11633 Oct 19 '16 at 21:08
-1

Had a similar issue. It was really bugging me. Here's what I did to fix it. Assuming your watch is on watch OS 3.0 (required). Try simply rebooting the watch after you've made all of your other setting changes. Totally worked for me. I hadn't rebooted the watch since the update.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .