Several iOS 10 apps enable typing suggestions by default, even if these were disabled prior to iOS 10. This is especially notable in Messages, where the suggestions include emoji.

How do I disable typing suggestions in iOS 10?


Tap and hold the language key (the one that looks like a globe or possibly an Emoji smile face) and set the toggle for "Predictive" to off.

  • 2
    nice, But iOS 9 show\hide predictive text was much better. Just swipe up and down. – ChintaN -Maddy- Ramani Sep 14 '16 at 8:40
  • 1
    Nice is in the eye of the beholder, I suppose. I was constantly flicking it on and off accidentally. – samh Sep 14 '16 at 11:46
  • I prefer the old way. Note: this solution doesn't work if you only keep one keyboard active in system settings (if you've disabled emoji). – jtheletter Oct 3 '16 at 14:55

If, like mine you do not get the option to change the keyboard on your messages app. Go to Settings > General > Keyboard > Predictive. Here you can switch it off.

  • This is such a confusing setting. I really believed it would entirely disable predictive text, but it was just the bar. Why doesn't it at least mention that? I prefer how iOS9 at least allowed you to drag the bar up and down – Matt Fletcher Jan 1 '18 at 16:32

The problem with this is that it also seems to shut off autocorrect and predictive text within the text bar -- I want nothing to do with the suggested words that can be tapped, but I like the autocorrect and suggestions that hover while typing. If that makes sense.

Update: Actually, this only seems to happen when turning off predictive text within the settings app. So this is good.

  • 2
    What exactly is your answer here? It's kind of hard to follow with the edit. – nohillside Sep 15 '16 at 19:37

You must log in to answer this question.

protected by Community Sep 16 '16 at 23:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .