Today, iOS 10 and watchOS 3 launched, however when I try to update my Apple Watch, I get "watchOS 2.2.1 Your software is up to date."

Obviously, it's not. According to this article, watchOS 3 is for sure out. The paired iPhone is an American (just to rule out possibility of any regional differences) iPhone 6s running iOS 10.0.1. I've tried opening and closing the app, restarting my iPhone, clearing RAM (by holding the power button down until the Slide To Power Off appears, then holding down the home button)---nothing. This iPhone was in the Beta Seed Program, but I just deleted that profile and restarted the iPhone just in case. Still doesn't work. Also, my internet connection is good enough (LTE at 5 mbps), so that shouldn't prevent it from at least searching for the update. I'm out of ideas here. Is there something I can do to resolve this now?

  • Did you update in the beta seed to the watchOS GM? If so, that's the same as the release. Commented Sep 14, 2016 at 0:25
  • @AlanShutko I was on the iOS 10 public beta, not the developers' beta, and AFAIK, watchOS 3 didn't have a public beta, so right now it's just running plain old watchOS 2.2.1. Commented Sep 14, 2016 at 0:28
  • I would just wait. It may take a few hours for all servers to mirror the update. I wouldn't start worrying until at least 24hrs has gone by.
    – Monomeeth
    Commented Sep 14, 2016 at 1:03

4 Answers 4


I forgot that I had installed the beta profile on my watch as well as my phone. As soon as I removed the beta profile from within the watch app and rebooted both phone and watch I was able to update to watchOS 3.

  • "Rebooted both phone and Watch". This was it. I forgot to restart my Watch after I deleted the Beta Profile, and just as soon as I did the update appeared. Thanks a lot. Commented Sep 14, 2016 at 15:59

This is typical and usual at major OS launches for short windows of time after release. Apple has hundreds to thousands of update servers and they roll out the announcement of the update progressively.

It is highly disruptive to get a stalled download since that uses CPU and battery - so preventing 10 downloads when the servers can only accommodate 2 makes each update go more smoothly once it starts.

I've not seen the slowness take more than 8 to 20 hours to level out - so if you are locked out for 2 days or more, you might contact support and/or try a different network connection.

If you want to try restarting the watch and the phone, perhaps that will jog a full check.


I had to delete the beta profile from my watch and iPhone. The update showed up right afterwards.


I had exactly the same issue! I found that deleting the watch beta profile, followed by restarting the watch and clearing phone RAM worked!! Hope this helps x

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .