0

I have a MacBook Air running OSX 10.11.6, and a WD My Cloud NAS device running Linux. It is no problem to copy files using a web interface, SFTP (i.e. SSH), and rsync.

When using Finder to access the network share (which I have mounted using the built-in feature in OS X) it is not working. I can list the files (they are listed slowly), but I cannot copy files to or from the NAS. I receive an Error code -36, which means an I/O error. I don't know how to find anything more specific.

I have tried using 1 byte files, as well as 2 GB files.

It works when accessing SMB shares on other network devices from my MacBook Air, as well as accessing the aforementioned SMB share from other computers. I can also use Time Machine on my MacBook Air to make backups onto the NAS. I.e. the only thing that doesn't work is the direct link between my MacBook Air and the NAS when using Finder.

Do you have any suggestions on how to fix this problem?

0

The problem was solved using the utility Keychain Access.app to delete the keys related to my NAS. After a restart, I had to provide login credentials, and copying files was once again possible.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .