0

I think this started with iOS 9. App updates often seem to fail quickly and require multiple presses of either the UPDATE button or the Update All link at the top. This happens both on iPad (4) and iPhone (6S). It sort of looks like the connection to the App Store quickly fails but later works - it is unlikely to fail once the progress bar has started.

There are a few tricks that help (repeated taps of the buttons; so many taps that the app store cache clears; killing and restarting the app store; restarting the device). However, the problem keeps coming back. It seems worse on the iPad, which is sometimes left unattended for a few days or a week. Later there are many pending updates.

It also often confuses pending updates with installed updates - the button changes from UPDATE to OPEN and the Update All button is present but greyed out. For the first ~half second this is not the case, so you can still install the updates if you are quick.

This sounds very similar to iOS App Store will not update apps unless the Update button is pressed many times. However, in this case there are no failure messages and resetting network settings has not fixed the issue. Also, iOS updates never fail for me.

  • I am also facing this issue after 10.0.1 update, just read it somewhere the bug has been fixed and will be patched in iOS 10.1 update. – onkar Sep 23 '16 at 9:10
  • Do you have a reference? Seems doubtful that it goes unfixed in the major release and then gets fixed in a minor, doesn't it? – Sam Brightman Sep 23 '16 at 16:51
  • 1
    ,Unable to fetch the original post , however Please go through comments in the following thread 9to5mac.com/2016/09/23/… Check Tony Turner's response to Tavish's Does the beta from yesterday include these fixes? comment. – onkar Sep 26 '16 at 10:15
  • I think @onkar is referring to this comment thread: 9to5mac.com/2016/09/23/… It's not clear whether there's only one bug here (not updating automatically vs failing manually vs mis-identifying updates as done), but potentially that is indeed a fix. – Sam Brightman Sep 26 '16 at 10:30
  • This is not fixed in 10.1. I haven't tried 10.1.1 yet. – Sam Brightman Nov 3 '16 at 7:48

You must log in to answer this question.

Browse other questions tagged .