1

Cmd+Opt+F should allow me to access the search box in many applications. It doesn't anymore though.

I have Karabiner running, but haven't specifically done anything with that combination. Just Ctrl+Opt+Cmd+Shift+F is assigned. When watching the keyboard events in the EventViewer, that comes with Karabiner, pressing the F doesn't register at all.

I remember that is has been working on and off before. Can't pin that down though. The global keyboard shortcut overview in the preferences doesn't show any action assigned to Cmd+Opt+F.

I am on El Capitan 10.11.6

What could be the issue? How can I further debug this?

  • I agree that Cmd + F is the standard search shortcut. But some applications, like Evernote, allow search on different levels. In the case of Evernote a search within the current node (Cmd + F) and a search for a note (Cmd + Opt + F). I wasn't clear on the Eventviewer thing. I do not have any other issues with the F key, only when Cmd and Opt are already pressed – Sandro Sep 14 '16 at 5:05
  • Wouldn't that imply that there is an interdependence between key states and events on the hardware level? From all I know about this stuff, that's all worked out in the OS and the keyboard only sends KeyUp and KeyDown events. If it's the keyboard, I'll have to face that, but I just don't see a high chance that it is. I'll switch off Karabiner and see what happens... – Sandro Sep 14 '16 at 12:31
  • True, I accidentially mispresented that in my OP. In my comment I added "I wasn't clear on the Eventviewer thing. I do not have any other issues with the F key, only when Cmd and Opt are already pressed". I'll switch it all off, test with Key Codes and report. Thx – Sandro Sep 14 '16 at 12:57
  • I switched off Karabiner and Keyboard Maestro. Makes no difference. Neither EventViewer nor Key Codes shows the firing of the F key when Cmd + Opt are pressed. I tried with all other modifier combinations and they work. And I looked through the global keyboard shortcuts in the settings again. Cmd + Opt + F is not used. But when I try to assign that combination as a global hotkey to some function it does work! That finally rules out the hardware issue :-) – Sandro Sep 14 '16 at 17:59
  • I still have the problem. What can I do? P.S.: It look like I am talking to myself above, but there were comments from another user, that he must have deleted. God knows why... – Sandro Dec 13 '16 at 7:40

You must log in to answer this question.

Browse other questions tagged .