0

I am trying to set my laptop's brightness level via nvram backlight-level= however I keep receiving errors, no matter how I try and input it. These are my past results.

~ nvram backlight-level "%96%06"
backlight-level %1e%00
nvram: Error getting variable - '%96%06': (iokit/common) data was not found
~ nvram backlight-level %96%06
backlight-level %1e%00
nvram: Error getting variable - '%96%06': (iokit/common) data was not found
~ nvram backlight-level\ %96\%06
nvram: Error getting variable - 'backlight-level %96%06': (iokit/common) data was not found
~ nvram backlight-level = %96%06
backlight-level %1e%00
nvram: Error setting variable - '': (iokit/common) invalid argument
~ nvram backlight-level = <%96%06>
zsh: parse error near `\n'
~ nvram backlight-level=<%96%06>
zsh: parse error near `\n'
~ nvram backlight-level=<%96%06>
zsh: parse error near `\n'
~ nvram backlight-level %96%06
backlight-level %1e%00
nvram: Error getting variable - '%96%06': (iokit/common) data was not found
~ nvram backlight-level="%96%06"
nvram: Error setting variable - 'backlight-level': (iokit/common) general error

However, I tried this suggestion but I receive this error.

nvram backlight-level=%96%06
nvram: Error setting variable - 'backlight-level': (iokit/common) general error

What is the issue here, I just am looking for the proper syntax.

0

You need to use sudo to write to the NVRAM (and it probably also won't hurt to prevent the shell from handling % by quoting it)

sudo nvram backlight-level='%96%06'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .