1

enter image description here

In the ten minutes since I have updated my OS I have restarted the computer three times (I was testing something with displays having separate spaces, and a restart is easier than logging in). Each time it's started back up I've had to uncheck that box.

After reading Cannot disable "Dark Menu Bar" on Mac OS I think there is a good chance my preference files have been corrupted (since installing El Capitan deleted all my system preference files). I don't know how to fix them.

I've never had a problem with the menu bar or it's color before. Can I stop this from happening a fourth or fifth time?

  • Did you try the solution proposed in the link you provided? – fsb Sep 12 '16 at 1:45
  • I did not. That problem is different than mine and I thought the answers where specific to it. Plus, none of the suggestions worked for the asker... But it is worth a try. – 345422 Sep 12 '16 at 1:48
2

Restart your Mac. Do not change any settings

Execute chmod -RN ~/Library/ in terminal.

It'll restore permissions for your library folder. After the command have finished running (it can take from seconds to several minutes) try to change the dark setting, and restart.

  • Okay. So that didn't work. This time my computer was sleep for about 13 hours and when I opened it the dark menu bar was back. I checked System Preferences (to do one of the suggestions from the post I linked) and decided to check Accessibility, which lead me to quitting f.lux. And as soon as the app closed my menu bar went back to normal. – 345422 Sep 14 '16 at 0:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .