22

I have installed macOS Sierra. I often work on my Mac while on the go, and then I play music using iTunes over my EarPods connected via the mini-Jack plug.

The button allows me to pause the music, but now in Sierra, every time I press it, I am asked whether I want to allow Siri. Refusing will simply bring the window up again when I press the button.

I don't want to use Siri on Sierra. At all. How can I prevent it from trying to activate when I press play/pause on my EarPods?

Added after reading comments: When I enable Siri, Siri doesn't activate when I press the button, unless I press it really long. But when I disable Siri entirely, it asks whether it's allowed to activate every time I press the button, even if it's just a short click.

7

It may be related to the fact that although you "disable" Siri, the process is still running. You can easily see that in the Activity Monitor, by searching for Siri.

If you try to kill it, it will be restarted by launchd. To stop the automatic restart, disable it by editing /System/Library/LaunchAgents/com.apple.Siri.plist and setting Disabled to false.

To do that, you first need to disable SIP (system integrity protection), edit /System/Library/LaunchAgents/com.apple.Siri.plist, then enable SIP.

  • If the Siri process is killed and re-launching disabled, does this have any other side effects on the OS? Also does this actually get rid of the popup window? – GlennG Oct 7 '16 at 8:54
  • 2
    It does get rid of the popup window. I've disabled Siri a couple of days ago, and I did not notice any side effects. – Marius Oct 8 '16 at 23:19
4

Sounds like a bug in Sierra. Submit a report. For now, enable Siri and just don't use it until it is patched.

  • @jornane I have the same issue and one way to get around it was to enable Siri and set the shortcut to something weird that I'll never use. eg: Shift + Ctrl + Alt + Cmd + S. This way Siri gets activated only when that combination is used - which I never do ;) For extra points, hide it from the menu bar. – Paul Ardeleanu Oct 3 '16 at 11:36
  • @PaulArdeleanu - didn't work. Turned on Siri, set it to something random, turned it off; pressing the headphone button brings up the annoying box. – GlennG Oct 5 '16 at 16:19
  • @GlennG No, no - you have to leave it turned on. – Paul Ardeleanu Oct 6 '16 at 17:32
  • Can't leave Siri on! That's the point of the question - getting rid of Siri – GlennG Oct 7 '16 at 8:49
  • 2
    Wasn't updated in Sierra 10.12.1 - still shows the popup – GlennG Oct 30 '16 at 19:48
1

On Sierra, you could only fix this by configuring the AirPods when paired with an iOS device.

On High Sierra, however, in the Bluetooth preference pane, once they're connected, an "options" button will appear:

options button

When clicked, this gives you an options list, which can independently configure the double-tap action for each ear:

options menu

0

You can disable it entirely in System Prefs > Siri

enter image description here

Pic from MacWorld : How to make Siri activate when you say ‘Hey Siri’ to your Mac with macOS Sierra which I imagine would be only of peripheral interest if you wish to disable it completely.

  • 1
    This looks interesting, but it doesn't solve my problem. I have now enabled Siri, set "Keyboard Shortcut" to "Off" and disabled Siri again. When I plug in EarPods and press the button on the cable, I still get a Siri pop up. – jornane Sep 12 '16 at 7:10
  • It works for me. Now, the earpods button just plays/pauses iTunes, and no dialog is shown. – Nicolas Miari Nov 10 '16 at 8:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .