When I try to update an app, and I go to the 'Updates' page, I Get this error in a dialogue box:

Could not load data from the Apple software update server.

I checked my Internet connection, everything is fine.

enter image description here

  • Do you know how long this has been happening for? Does the App Store app indicate you have any updates? And have you tried logging out of your account and logging back in?
    – Monomeeth
    Sep 18, 2016 at 7:47
  • Tried everything Sep 18, 2016 at 10:34
  • Please check I've added Step 4.
    – dante12
    Sep 18, 2016 at 10:59
  • Try close App Store, then open Apple Menu  -> About This Mac -> Software Update…
    – Ivan Chau
    Sep 18, 2016 at 11:24
  • Have you tried deleting "/Library/Preferences/com.apple.SoftwareUpdate.plist", restarting your Mac and then trying again?
    – MorganR
    Sep 19, 2016 at 12:08

6 Answers 6


Please backup all your data. Example: with Time Machine or similar Software (if you not use Time Machine).

All steps are complete in itself. If any of these works you don't need the other steps.

Step 1: Appstore

  1. Open the Appstore and choose from the Menu Store the option to show your Account. You need your AppleID password to access to your account.
  2. If you have access to your account, click on the button reset all warnings.
  3. Log out from the Appstore and close the app. Start Appstore again
  4. Log in to your AppleID by using the option from the Store menu.
  5. Test if the update process works.

Step 2: Using Terminal

  1. Open your Terminal. Choosing from the Finder Menu Go To.. the Option Utilities. Start the Terminal.app

  2. Type or insert the following command in your Terminal and hit Enter.

    softwareupdate -i -a

If this not work or you got an error use the following command.

    sudo softwareupdate -i -a  

Test whether AppStore updates work.

Step 3: The Hard Way

Reset PRAM
To Reset PRAM, restart the Mac and hold the keys CMD+Option (Alt)+P+R simultaneously during startup. Hold down the keys until you hear the second sound output.

Move the following files to the trash or on your Desktop. Close the AppStore before using the following instructions.

  1. Click on the Finder Desktop and press the keys CMD+Shift+G.
  2. Insert the following Line in the window and press Enter.


Delete the following files (if exists)


  1. Restart your mac and test if works.

Step 4: Use Debug menu

  1. Close App Store with CMD+Q

  2. Open Terminal and insert the following Command:

    defaults write com.apple.appstore ShowDebugMenu -bool true

  3. Open App Store and choose from the Debug Menu Show download Folder

  4. Close App Store and move the Download folder to the trash.

  5. Restart your mac (this is important), empty the trash and try if app store works.

  • Nope. tried all three, but none of them work :( . I did not have com.apple.appstore.plist and com.apple.storeagent.plist. Sep 18, 2016 at 10:33
  • Added Step 4 check whether it works.
    – dante12
    Sep 18, 2016 at 10:55
  • Don't get any debug menu :(. Is it on the bar where it says 'App Store Edit Store'? Where else can it be? Sep 18, 2016 at 14:46
  • This is an extra menu next to the help menu. If you insert the following command in the Terminal do you receive any output? defaults read com.apple.appstore
    – dante12
    Sep 18, 2016 at 14:53
  • yes. I get an output. it is too long to post as a comment. see it on github here: github.com/suryanisaac/Errors/blob/master/… Sep 18, 2016 at 23:28

A similar experience happened to me a few months back. I fixed it by clearing the Caches folder:

  1. Go to: ~/Library/Caches
  2. Move everything here to the Trash
  3. Empty the trash.
  4. Restart your Mac

Clearing the Cache folder is perfectly safe.

Reference: Trying to Free Up Space - Can I Delete Library Cache?


It could be hosts issues

Make sure your /etc/hosts file looks like something like this:

# Host Database
# localhost is used to configure the loopback interface
# when the system is booting.  Do not change this entry.
##       localhost broadcasthost
::1             localhost
fe80::1%lo0     localhost

Remove any gs.apple.com entries.

See: https://support.apple.com/en-ca/HT201442

It could be dns issues

Maybe you have inappropriate DNS configured.


See: http://osxdaily.com/2015/12/05/change-dns-server-settings-mac-os-x/


I had a similar issue and this resolved the issue in my case. I had this entry in the /etc/hosts file: osxapps.itunes.apple.com

I was able to download updates after removing the entry without doing a system restart.


I had the same issue. It transpires that I had moved from Australia to the UK and the apps that were causing the issue were installed when I was in Australia.

To solve the issue I had to logout from my UK AppStore Account and logon using my Australian AppStore account. Once I did this and chose to update the apps it all worked.

Oh, make sure you logout of the old Appstore account and back in with your current region's account when finished.


For me, the command that resolved this was:

sudo softwareupdate --clear-catalog

(Found here: https://apple.stackexchange.com/a/221419/238906)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .