53

Apple has removed PPTP VPN support in Sierra due to security concerns. See: https://support.apple.com/en-us/HT206844

Unfortunately, I need to connect to an organisation that only supports PPTP (not my decision).

I know about Shimo, but it's $50 and has a lot of features I don't need.

I was hoping to find a free or open source solution? A command-line-only option would be fine for macOS.

I'm even open to more esoteric solutions (e.g. a lightweight linux VM that connects to the VPN, and then shares the connection with host OS, but not sure how feasible this would be or how to do it).

Edit: I see the command-line tool pppd is still present in macOS Sierra, so perhaps it's possible to call this directly?

Edit 2: I tried following this tutorial with an options file from the ArchWiki, and a custom route in /etc/ppp/ip-up, but it gives an error (publish_entry SCDSet() failed: Success!) when I try to run the pppd command, the pppd daemon doesn't seem to be running, and the ppp0 interface isn't showing up in ifconfig. I don't know much about networks and network interfaces, so I'm finding this very confusing! Any help would be much appreciated.

  • 1
    Turns out, iOS 10 dropping PPTP was enough for them to finally support OpenVPN, so thanks Apple! (I guess?) Hopefully there's still a solution to this question for those that need it though. – Matthew Sep 20 '16 at 5:22
  • I have an ASUS RT-N56U router that only supports PPTP. So this question is still valid. – adib Oct 22 '16 at 20:45
  • Nice one, crapple. When it comes to security, users are usually the weakest link. Maybe they should get rid of those too. – Daniel Nov 9 '16 at 12:42
  • I have wrote tutorial how to connect using terminal filipmolcik.com/pptp-vpn-on-macos-sierra-and-high-sierra – Filip Molcik Jan 31 at 15:53
26

The FlowVPN client is free (and works with any provider).

It supports PPTP and OpenVPN on macOS Sierra and High Sierra:

https://www.flowvpn.com/download-mac/

Just overwrite the FlowVPN server address with any server and it connects.

  • 2
    How to overwrite the FlowVPN server address? It is a drop-down menu. – SparkAndShine Nov 20 '16 at 0:18
  • 2
    @sparkandshine You can type inside the dropdown menu if you place your cursor in it :) – ThomasCle Nov 29 '16 at 7:13
  • 1
    Thanks for the suggestion. Unfortunately, for me FlowVPN didn’t work (PPTP error when reading header : read -1, expected 12 bytes), whereas Shimo does. – Blaise Mar 16 '17 at 19:07
  • 3
    for me it get stuck at connecting: Mon Apr 10 17:31:37 2017 : pptp_wait_input: Address added. previous interface setting (name: en0, address: 192.168.2.25), current interface setting (name: ppp0, family: PPP, address: 192.168.5.25, subnet: 255.255.255.0, destination: 192.168.5.1). Mon Apr 10 17:31:41 2017 : PPTP port-mapping update for en0 ignored: VPN is the Primary interface. Public Address: 0, Protocol: None, Private Port: 0, Public Port: 0 Mon Apr 10 17:31:41 2017 : PPTP clearing port-mapping for en0 – Amir Apr 10 '17 at 21:33
  • 1
    @RichAble FlowVPN is no longer free. Is there a terminal alternative for vpnc – SumNeuron Jun 6 '17 at 13:29
0

Just paid $55 for Shimo 4. It works. A google search for Shimo 4 VPN will guide your to the correct link. It supports PPTP, L2TP, OpenVPN, SSH, and a few more. I even found I can connect to some L2TP server with Shimo while I cannot connect with the built-in OS X VPN client. The price is a bit expensive, but it works pretty well for me, so I paid for it. I guess they might have some sales boost as the new OS X rolled out.

  • Welcome to Ask Different! We're trying to find the best answers and those answers will provide info as to why they're the best. Explain why you think the software you recommended is better than others out there. Providing links can also help the OP, and others, find the software and evaluate it themselves. See How to Answer on how to provide a quality answer. - From Review – fsb Sep 21 '16 at 20:32
  • OP wrote: “I was hoping to find a free or open source solution?” and explicitly mentioned why they are not using Shimo. – Andrea Lazzarotto May 15 '17 at 10:11
  • @AndreaLazzarotto it's interesting. I'm wondering if OP added it after my post. But I'm not sure. I guess I didn't read about it when I posted my answer. Should I read it, I definitely would not post it. – Elgs Qian Chen May 15 '17 at 10:18
  • 1
    Shimo provides free licenses to students if you sign up with your educational institution's email address: shimovpn.com/students – Benjamin B. Oct 4 '17 at 15:43
0

I found this when searching for how to fix a error I was getting in Shimo when trying to connect to PPTP VPN. I didn't get many helpful search results so even though this doesn't answer the original question, others might land here looking for help for this error:

LCP: timeout sending Config-Requests

I'm running a trial of Shimo on OS X 10.12 (Sierra) and the VPN server is on Windows 2012 R2.

I also posted this answer on another question because it helped me work out the solution. A recommendation posted by @wgui was to use the 'silent' option which didn't work but the description given for 'silent' lead me to figuring it out.

The fix for me was to use the 'passive' option. In Shimo, it can be enabled in the 'Expert' section. You should see it as one of the choices given when you add a parameter key (just leave the value blank). Once it was set my connection worked fine.

-1

VPN Tracker also supports PPTP it's not free but presumed to be the most professional VPN Software for the Mac. PPTP connections are automatically imported into VPN Tracker if launched on El Capitan prior to the upgrade and if the connection fails, there is a professional support team. Yes it's a paid product.

You must log in to answer this question.

protected by Community Oct 27 '16 at 6:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .