0

I often paste stuff into my terminal from websites, sometimes with newlines in wrong places, sometimes with newlines where you would expect them. However, iTerm seems to ignore any paste that contains newlines. This often leaves me confused as to wether I copied the contents of the text I wanted to paste correctly, and when I've found out that I copied them the way I wanted to, I have to reformat those lines in some text editor which all unnecessarily breaks flow. Above that, iTerm also has this weird feature that always pastes slowly instead of just putting the clipboard contents there. I know these things might have been implemented for safety reasons, but I can tell you now that I am going to execute every command I want to execute, wether they have newlines in them or not.

I've fixed this last annoyance kinda by altering some sort of delays or something in the preferences, but I would kinda rather get rid of these features and let iTerm behave as Apple's terminal app, or any OS X application for that matter. Anyone know how to tackle this problem?

  • Can anyone elaborate on the down vote? Not the right place or not an interesting enough question? – rien333 Sep 10 '16 at 16:11
0

You hit a bug. Upgrade to 3.0.9 to fix it.

  • I'm actually on the nightly builds, but I guess I will try out that version – rien333 Sep 11 '16 at 10:42
  • Thanks, that seemed to work. It's still pastes relatively slow, but at least it's doable. – rien333 Sep 11 '16 at 10:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .