Dec 2018 Update:

I bought a new battery (A1322) in Sep 2016 for S$42 because my battery deteriorated further. My MacBook recognised the battery and it had no random shutdowns for a while. However, it was a bad choice because the new battery barely lasted me for a few months before it started to expand. It pushed against the MacBook trackpad until it cracked the trackpad glass.

With that, I decided to say goodbye to my old MBP and I bought a new MBP in Jan 2017.

My MacBook Pro (13-inch, Early 2011) (aka MacBookPro8,1) running OS X 10.10.5 Yosemite has just crossed the 1000 battery cycle count mark.

It now suffers from random shutdowns without me prompting anything. I am sure it is not a userland software problem.

What I have done:

  • reset my SMC several times
  • checked Console.app for .panic files - none exists

So I read further and found that Apple says upgrade your SMC to 1.69f4 (SMC 1.7). My current SMC version is 1.68f99. However, the update installer throws an alert:

The update is not supported by your system.

Turns out the system requirements are

OS X 10.7.5

OS X 10.8.2

but I am running Yosemite. Any advice?

  • The KB says "This update is recommended for MacBook Pro (Mid 2010) and MacBook Pro (Early 2011) 15 and 17 inch models." Doesn't mention the 13". Did you check what Firmware you already have?
    – Tetsujin
    Sep 9, 2016 at 9:59
  • 1
    @Tetsujin I current have a SMC version of 1.68f99
    – hongsy
    Sep 9, 2016 at 20:37
  • It's too late now to roll it back & experiment on it to confirm it. But my 8,2 15" Earl11 never had Lion or Mountain Lion on it (Staright form 10.6 to .9) and is now at SMC Version (system): 1.69f4. (The Apple KB lists 1.68f99). But also BootROM is out of sync with Apple KB (is now MBP81.0050.B00 due to High Sierra experiments) Sep 20, 2018 at 10:13
  • Hey @hongsy Did you find any fix to that issue? I have the same problem > I still suffer from my old SMC problem although it is less noticeable. specifically my mac still suffer from unexpected shutdowns (roughly at 7% battery life)
    – Lokman
    Dec 26, 2018 at 10:52

2 Answers 2


any luck with your issue? I am having SMC related issues on my early 2011 13-inch MacBook Pro (aka MacBookPro8,1) too. Also want to update SMC to 1.69f4 but on Sierra I'm not allowed to.

Curiously, the description for this update on Apple's website doesn't specifically list the 13-inch model. Also curiously, digging into the .pkg file there are 4 other packages, named MacBookProSMCUpdate, MBP18, MBP91 and MBP92, which contain the SMC file for the following models, respectively:

  • MacBookProSMCUpdate: 2010 17-inch MacBook Pro
  • MBP18: 2010 15-inch MacBook Pro
  • MBP91: 2011 15-inch MacBook Pro
  • MBP92: 2011 17-inch MacBook Pro

This info was retrieved from the names of folders/files buried within payload files.

That all seems to indicate that, although this update is listed on Apple's website as for the early 2011 13-inch MacBook Pro, the software inside is intended to use in other machines. Either that or Apple used totally inconsistent naming for the files and folder inside the package.

With some more digging, I found that I COULD manually install an SMC update through an EFI command-line mode in rEFInd. I have not yet attempted that as I'm aware of the risks and don't want to finish bricking my Mac with a wrong SMC firmware.

So i guess my question is: Has anyone with the same Mac model successfully updated its SMC firmware with version 1.7 (1.69f4) and can confirm that it is INDEED intended for this Mac model (MacbookPro8,1)?

If not, is there any other official word from Apple regarding the right number of the latest SMC update for this model?

Any hints are appreciated!

  • Whoops, disregard my previous comment (I misread your post). A less risky approach might be to install 10.7 to an external USB, then install the firmware update from there. You might also check that the EFI boot ROM is up to date, listed here alongside the SMC versions: support.apple.com/en-us/HT201518 Dec 13, 2016 at 3:25
  • Thank you for the reply. I'll try that and post the results back here. Dec 13, 2016 at 17:42
  • I tried installing the SMC update from 10.7 and 10.8, to no success. The EFI boot ROM is up to date. I think my last resort is trying from the EFI command-line through rEFInd.Also considering replacing the battery (although I'm convinced that it's an SMC issue – got the MacBook Pro to start up from the battery once, but can't tell how it happened) or taking it to repair (hope they don't make me buy a new logic board). Dec 15, 2016 at 2:16
  • hey @alvaroantonio i did suspect that Apple have some inconsistencies with the .pkgs. unfortunately my Mac's battery deteriorated further until it was impossible to not upgrade and so I bought a new battery for my Mac. my SMC is still at 1.68f99 though
    – hongsy
    Dec 16, 2016 at 23:53
  • hi @hongsy, after you replaced your battery is everything running smooth? does the mac recognise the battery? any problems related to SMC (fan running at full speed all the time, trouble reading battery status, key backlight not working)? I'm considering this may be the only solution now... Dec 17, 2016 at 16:37

There seems to be a problem on the Apple KnowledgeBase page.

MacBook Pro (15-inch, Early 2011) MacBookPro8,2 1.68f99 (SMC 1.6)
MacBook Pro (13-inch, Early 2011) MacBookPro8,1 1.69f4 (SMC 1.7)

Both of these packages have the same name without version numbers when downloaded.
Both seem to address the same thing or kind of problem:

MacBook Pro SMC Firmware Update 1.6:

This update addresses a rare issue on some Apple notebooks where a battery that has accumulated more than 1000 charge cycles may unexpectedly shut down or stop functioning.

Post Date: Jan 30, 2013 –– File Size: 666 KB ––
System Requirements: OS X 10.6.8, OS X 10.7.5, OS X 10.8.2 or later

Containin the actual files : 2010MacBookPro13SMC16, 2011MacBookPro13SMC16

MacBook Pro SMC Firmware Update 1.7

This update is recommended for MacBook Pro (Mid 2010) and MacBook Pro (Early 2011) 15 and 17 inch models.
This update addresses a rare issue on some Apple notebooks where a battery that has accumulated more than 1000 charge cycles may unexpectedly shut down or stop functioning.

Post Date: Dec 12, 2012 –– File Size: 703 KB ––
System Requirements: OS X 10.7.5, OS X 10.8.2

Containing the actual files: 2010MacBookPro15SMC17, 2010MacBookPro17SMC17, 2011MacBookPro15SMC17, 2011MBP17.smc

That makes the version
"SMC Update 1.6"
the right one for your model MacBook Pro 13inch 8,1 Early 2011.

What is the problem on Apple's page?

They seem to have switched the SMC version numbers around, wrongly.

On a MacBook Pro 8,2 15inch Early 2011 the version number is 1.69f4. (Can't check 13inch now.)

Effectively Apple says per the table on its knowledgebase page: "Upgrade to SMC1.7" but meant to say 'upgrade to SMC1.6'? SMC1.6 contains Version: 1.68f99. (That's what the binary identifies itself with at least)

2011MBP13.smc   Version: 1.68f99
2011MBP15.smc   Version: 1.69f4

As to the supported versions of Mac OS X form which to run thiese updaters:
My 2011s went from Snow Leopard straight to Mavericks. Either this update (1.7 in this case) was supported in Mavericks as well or I booted temporarily into a version of (Mountain) Lion on an external drive just to apply this update.

Therefore it seems that you guessed at the problem and found bad advice on Apple's part on one page relating to version numbers that you read correctly.
If you are already on the latest SMC version for your machine, it may be a hardware problem with your battery after all.

As a limited workaround in general to get the latest versions of firmwares: Apple doesn't distribute these as standalone packages anymore, as the above (outdated) page demonstrates.
You might still get the latest for your machine by installing a later version of macOS onto an external drive, which now should prompt an update of those components en passant. These versions should then still be available in or work with Yosemite, if you want to keep that system.
(As I can't check 13inch, for SMC I have no data, but your EFi BootRom will get an update if you install High Sierra at least. For 2011 MBPs you'll go from MBP81.0047.2AB (2015-001, standalone) to Boot ROM Version: MBP81.0050.B00).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .