I've got a 10.11.6 (El Capitan) tower with separate drives for OS X and Windows 7 via Bootcamp, which I also use via Parallels. I went to shut down the Win 7 VM via Parallels yesterday and it wanted to 'finish' installing a bunch of Windows Updates. I let it run for hours and it was still stuck on 1 of 32(ish) so I reluctantly killed it. After this it was failing to boot up again, so I figured I'd reboot the entire machine into Win 7 to fix it... big mistake apparently.

The automatic repair options in Windows are all failing to correct the problem. Rolling back to a previous known good state fails. System restore fails. Safe mode blue screens at login. I have a Windows 7 install CD but can't get the system to boot to it and restore the OS. Tapping F8 at startup gives me some more options but restore via CD doesn't seem to be one.

The worst part is that holding the option key down at boot leaves me with a black screen so I can't select to boot back into OS X. I tried using 'X' from the list here but no dice on that either (just proceeds to fail to boot into windows again).

Would love to hear any other ideas about repairing the windows installation or getting back into OS X.

  • "(El Capitan) tower"... a Mac Pro? If it's anything other than the 2013, try removing one or other of the drives & see what happens.
    – Tetsujin
    Sep 7, 2016 at 16:30
  • yeah, 6 core tower from like 2011 or so. when I remove the windows drive it just says "operating system missing" or something to that effect. clearly still trying to boot into windows, has that distinctive DOS font.
    – Ty W
    Sep 7, 2016 at 17:11
  • 2011 ought to be able to boot to Recovery, hold Cmd/R at the boot chimes. If that fails it ought to automatically switch to Internet Recovery, assuming you have a connection [preferably wired, definitely not captive portal etc] From there you at least have a basic toolkit. Add info to your question on how far down that avenue you can get & we can see what's next.
    – Tetsujin
    Sep 7, 2016 at 17:15
  • tried command-R and ended up back into the failed windows startup I believe. might've been black screen. will have to try again after lunch here.
    – Ty W
    Sep 7, 2016 at 17:43
  • Ahhh... Mac Pro can't do internet recovery :/ You're gonna need a boot USB/CD
    – Tetsujin
    Sep 7, 2016 at 17:54

1 Answer 1


I pulled the windows drive and put it in a windows machine to repair it and got it booting over there, but it still wouldn't boot when put back into my Mac Pro.

I was able to get my Mac Pro to boot back into OS X by resetting NVRAM (command-option-P-R after startup sound until you hear it again). Apparently this contains boot disk preference and resetting it along with pulling the windows drive let it 'find' OS X again.

I believe the reason that OS X Recovery and holding option for the Startup Manager don't work for me is due to an aftermarket GTX 760 graphics card. It works great on successful boot, however it doesn't behave the same as the OEM card did in the EFI.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .