58

I installed Docker on OS X, and now it automatically loads every time I log in. Is there a way to stop this?

0

2 Answers 2

73

Click the Docker icon in the right hand side of the menu bar, and click "Preferences". In the dialog that appears, untick "Automatically start Docker when you log in".

Screenshot

6
  • 3
    Do you know what's causing it to run? It's not one of the Login Items (in System Preferences).
    – mjs
    Sep 9, 2016 at 22:20
  • 7
    @mjs It's a launchd service. You'll see two Docker services when running launchctl list | grep docker.
    – kba
    Jan 14, 2018 at 5:44
  • 2
    Do you know where its plist is stored? Can't find it on my system.
    – not2savvy
    Mar 18, 2018 at 15:11
  • I had both 'Docker' And 'Docker Desktop' installed. I had to open the one called 'Docker' and then click the cog-wheel symbol, in the top right. There was no 'Preferences' if I clicked on 'Docker' in the top bar.
    – Zeth
    Jul 30, 2021 at 11:57
  • 1
    None of these solutions work for me. The option under "Preferences" is definitely not checked, and I've done a launchctl remove on both the entries, but after a reboot it comes back!
    – stevec
    Aug 24, 2021 at 18:59
13

The locations are

cd ~/Library/LaunchAgents
cd ~/Library/LaunchDaemons

cd ~/Library/LaunchAgents
cd ~/Library/LaunchDaemons

But I recommend you just remove using launchctl remove

launchctl list | grep docker

launchctl remove com.docker.helper
launchctl remove com.docker.docker.11008
1
  • 1
    I think this is a better approach, because I also have other application having the same issue. and I don't need to go to each application to remove them from launch. I was able to remove my another application by removing it in LaunchAgents but I can't do it with launchctl remove though, they will still launch on startup after i restart my laptop
    – Peter Paul
    Nov 30, 2020 at 15:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .