-2

I just installed a 6TB HDD in a 2008 Mac Pro with 10.11.4 and am trying to make a symlink on it, ln -s /origin /destination, but I get Permission denied errors. I then tried to just create a file with touch but got the permissions error again.

On the other 500GB SSD and 320GB HDD in the machine I have no such issue.

  • 2
    Have you checked the perms on the drive, checked it's GUID/HFS+, tested with 'ignore ownership' ? – Tetsujin Sep 7 '16 at 6:43
  • @techraf what details are you looking for? I listed my OS, what commands I ran, the response I got, and tests on other drives, which passed. Not sure what else I could include. – CR47 Sep 7 '16 at 13:04
1

Solved it by doing the following:

1) Select your home directory (the folder named after your computer's login) and press Command-I to "Get Info"

2) Scroll down to the "Sharing & Permissions" section at the bottom of the Get Info window

3) If everything is grayed out, click on the gold lock at the bottom right of the window. You'll be prompted for your login password. You'll need admin access to edit the permissions. If you are unable to unlock these privileges, talk to your system administrator to give you access to this folder.

4) Your name should already be on the list of sharing and permissions. If you aren't listed, then add yourself by clicking the + button.

5) Once your user is added, click your name and then click the gear menu at the bottom middle of the window, and choose "Make me the owner". If this option is grayed out you can skip to step 6.

6) Click the gear again and choose "Apply to enclosed items".

7) Restart

Source

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .