MBP function keys f1 through f9 are not responding: brightness up/down, keyboard backlighting up/down, etc.

Seems to be a fairly common problem looking through forum posts online.

Seems to have something to do with windows - people are having problems with VMware / boot camp, etc. My problem is probably of the same variety.

Volume keys work (f10, f11, f12).

fn + function key also has no response.

Tried toggling the use fn key option is keyboard settings but that only seemed to make volume keys (f10, f11, f12) respond with random functions.

Any ideas?

edit; formatted the disk - reinstalled os - still the same.

  • Have you tested this using an external keyboard? If an external keyboard doesn't work, than we know it's a software issue. If it does work than it's likely a hardware issue one way or another. Either way, testing this way helps to narrow down the problem.
    – Monomeeth
    Commented Sep 9, 2016 at 14:21
  • Also, can you clarify what model MBP you're using and what version of Mac OS you're running!
    – Monomeeth
    Commented Sep 9, 2016 at 14:21
  • 13-inch mid 2012 / 10.11.6
    – Mou某
    Commented Sep 9, 2016 at 14:23
  • Very strange... Do those keys light up when you show the keyboard viewer? System Prefs > Keyboard > "Show Keyboard, Emoji, & Symbol Viewers in menu bar" then choose Show Keyboard Viewer from the new menu that appeared. On my Mac I didn't see them light up until I pressed fn, FYI.
    – MacManager
    Commented Sep 9, 2016 at 20:20
  • Do you have "Use F1, F2, etc. as standard function keys" turned on or off in System Preferences -> Keyboard?
    – owlswipe
    Commented Sep 10, 2016 at 0:02

2 Answers 2


Okay, it's a bit hard to try and troubleshoot this via lots of comments to and fro, so I will use this to try and get you sorted.

I'm assuming that since you've already tried formatting the disk and reinstalling OS X that you already have a recent backup. If not, do one now.

Try an external keyboard

As I mentioned in the comments, have you tried using an external keyboard? Any USB keyboard will suffice - give it a go and report back your findings. Basically, troubleshooting is a process of elimination. This simple test will greatly reduce the number of possibilities and help troubleshoot your issue.

Reset your PRAM/NVRAM

Older Macs had what's called Parameter RAM (PRAM), newer Macs use Non-Volatile Random-Access Memory (NVRAM). Here’s how to reset your PRAM/NVRAM:

  1. Shut down your machine. Yes, a full shut down, not just logging out.
  2. Press the power button and then press the command-option-p-r keys. You have to make sure you press these keys before the gray screen appears or it won’t work.
  3. Hold those keys down until your Mac reboots again and you here the startup chime.
  4. Let go of the keys and let your Mac reboot normally.

Note: When you log back in you may need to readjust some of your system preferences (e.g. mouse speed, time and date/timezone, etc).

Reset the SMC

Your computer's System Management Controller (SMC) can also be reset. The instructions for resetting your SMC depend on three things:

  • Does your device run from a built-in battery? (In your case, yes)
  • Does your device run from a removable battery?
  • Does your device just run off power from the wall?

Now, for the sake of others who may come here looking for answers to the same issue, I will provide the process for all three.

For MacBook Pros, MacBook Airs, and MacBooks where you can’t remove the battery on your own (i.e. it's a built-in battery), here’s what you do:

  1. Shut down your computer
  2. Keep the MagSafe adapter (power cable) plugged in.
  3. Press at the same time shift-option-control (on the left side of the keyboard) and the power button
  4. Let go
  5. Turn your computer back on with the power button.

For MacBook Pros, MacBooks etc that you can remove the battery from, here’s what you do:

  1. Shut down your computer
  2. Disconnect the MagSafe plug (power cable) from the computer
  3. Remove the battery
  4. Press the power button for 5 seconds and release
  5. Put the battery back in
  6. Reconnect the MagSafe cord (or power cable)
  7. Turn your computer back on with the power button

For iMacs, Mac Pros, Mac Minis, etc that only run from a power point in the wall

  1. Shut down your computer
  2. Unplug it from the power
  3. Press and hold the power button for 5 seconds
  4. Plug it back in and turn it on.

Hope this helps. Please report back and let us know.


I had the same problem after replaced the thermal paste. struggled the same for a while and found the solution. it is actually easy: first of all, it must be hardware issue, I remembered when I was trying to disconnect battery before I replace the thermal paste, I wrongly disconnect one of the keyboard connectors(not the keyboard ribbon), there is separate connector for F keys, after go back and secured the connector, everything came back. so rule of thumb is to double check all the connections on logic board.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .