1

I recently restored my 2013 MacBook Pro El Capitan system back to Mavericks from my Time Machine external drive. The restore was successful except a few that wont start: Calendar, Terminal, Messages, App Store. I tried loggin in as guest, same problem.

  • Do you get an error message? Do they appear bouncing on the Dock? – grg Sep 6 '16 at 21:49
  • When I click on the apps, they bounce once but never open. No error message! – doug Sep 6 '16 at 22:19
1

If these were 3rd party apps I'd say that you need to reinstall them but they aren't so it's a bit... odder...

It may be that the Time Machine restore put back files that were created with a later version of the app that the older version understands. I would start with deleting the preferences files for those apps in ~/Library/Preferences. Look for files that start with "com.apple" and end with the app name. You could also check in /Library/Preferences. Delete the preference file(s) and try the app again.

Apps like Calendar have a file that they automatically open. you may have to just delete the primary calendar 'document' which (I believe) have their own folder in which they reside: ~/Library.

Finally clear the caches folders Delete the contents of /Library/Caches and ~/Library/Caches and reboot.

At least that is my best guess.

  • When I restored from Time machine, it would have put back the version of Calendar that ran under MAvs. I cant restore the Cal app alone because it wont allow it to be changed like that. I had the setting for Time machine so that caches were not being backed up, maybe thats the problem. I tried trashing prefs from user and HD. – doug Sep 7 '16 at 17:17
  • Or you could try it with one app and see if it works, often solutions to computer issues are counter intuitive. – Steve Chambers Sep 7 '16 at 22:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .